Bug fixed in 9.0.0

Update There is now an official response from Wolfram Support on this issue.

Having recently installed Mathematica version 9 64-bit on Windows 7, I keep running into Self-Test Errors evaluating certain expressions. For example, if I evaluate:

Piecewise[{{0, x < 10}, {1, True}}]

then this message pops up:


The output cell did not render properly and, when I hover over the cell, the following additional message pops up:

The stretchable character 0xf361 in the Mathematica5Mono font (size 13) has a repeating piece (0xb2) that is zero size.

The same SELF-TEST error pops up if I type ESCpwESC in an input cell.

This error occurrs on two different Windows 7 machines, installing the Standard Edition on one and the Home Edition on the other. Both machines also have versions 7 and 8 installed. On the Standard Edition machine, it is very likely that Mathematica had been run many times before installation after the last reboot. But on the Home Edition machine the installation was the first thing done after power-on.

Interestingly, my pre-existing installations of version 7 and version 8 both exhibit this behaviour now. They worked prior to installing version 9.

How can I fix this?


Some users report getting a Windows "Blue Screen of Death" (BSOD) performing these or similar operations.

  • $\begingroup$ +1. I have a similar problem, only my machine bluescreens when Mathematica tries to render the piecewise symbol, or when I open the fonts control panel folder. I "fixed" it by removing the Mathematica5.ttf font. I thought this was a bug in my video driver, but maybe something's wrong with this ttf file. $\endgroup$ Commented Nov 30, 2012 at 17:26
  • $\begingroup$ Great! Your answer worked on my machine, too. No more bluescreens when I enter [esc]pw[esc]! $\endgroup$ Commented Nov 30, 2012 at 17:35
  • $\begingroup$ Just out of interest (haven't been able to find out) - is this a perfectly valid font that Windows can't handle, or is the font unusual in any way? Character 0xf361 doesn't seem to be anything much... $\endgroup$
    – cormullion
    Commented Dec 1, 2012 at 14:07
  • 1
    $\begingroup$ @cormullion As far as I can tell, there is nothing wrong with the font file itself, or the way Windows handles it. The problem lies in the way the file was being installed. Judging from what the installer did to my system, it looks like WRI changed or mistyped the name of the font somewhere along the line (switching dashes to spaces or vice versa). The V8 installer had this problem as well. It is good to see that WRI have nailed it down this time with the patch. Character 0xf361 is in one of the Unicode "private use" areas. Mathematica uses that codepoint for the piecewise bracket. $\endgroup$
    – WReach
    Commented Dec 1, 2012 at 16:13
  • 1
    $\begingroup$ We're still not sure why Windows blue-screens. Every blue-screen is a Windows bug (unless it's a driver bug, but I think this is probably Windows), and of course, we can't easily debug Windows. But WReach is right in saying that there was a naming inconsistency on one of the Mathematica5 font variants in the past which may have contributed to this mess. The installer works now by forcibly uninstalling the old font file and its corresponding registry entry. In simple terms, the installer was previously "polite" about this step...now it's "aggressive". $\endgroup$
    – John Fultz
    Commented Dec 4, 2012 at 15:03

1 Answer 1


Arnoud Buzing in chat made us aware of this support page that discusses possibly related issues.


A new version of the Windows installer has been placed on the Wolfram Portal. Its file hash is: F3EEC3AFEC3186001A1A237C88B7A991

You can check this with the following command:

BaseForm[FileHash["Mathematica_9.0.0_WIN.exe", "MD5"], 16]
  • $\begingroup$ My answer is now rendered obsolete -- the .EXE on that support page performs essentially the same operations (in a much more convenient package). $\endgroup$
    – WReach
    Commented Nov 30, 2012 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.