Bug introduced in 10.0 or earlier and persisting through 10.2 or later

I use FontFamily->"Webdings" in interfaces in several places, but among other things for custom opener icons, for example I use the following "icons" for open and closed openers:

enter image description here

In version 10 this is what happens:

enter image description here

Both screen grabs are taken on the same computer. Webdings is installed. I open V9 and evaluate and take a grab. I close V9 and open V10 and do the same.

I knew the Mathematica fonts were different in V10 compared to V9 but I don't understand why Webdings would be being rendered differently. I've tested a hand full of other fonts, including Wingdings, and have not observed any difference between V9 and V10. Can anyone enlighten me why Webdings is now different?

I'm on OS X 10.9.4 but my interfaces have worked on both Windows and Mac with V9.


I always use OS X. On my current machine I am running OS X 10.9.4. I have V8, V9, and V10 installed. None of these have a /SystemFiles/CharacterEncodings/Webdings.m

Regarding the error message that @m_goldberg gets when using FromCharacterCode. The same message occurs in V8 and V9 so I think that is irrelevant to the present issue.


enter image description here


enter image description here

So the same error message occurs for FromCharacterCode in previous versions but it clearly has no bearing on the using of Style[6,FontFamily->"Webdings"].

The present issue is that you could use Webdings as a font in V8 and V9 on OS X and now you can't.

  • $\begingroup$ I see the correct glyphs as shown (first image) in V10 under Windows. I presume you have an actual font with the name Webdings installed? $\endgroup$
    – Mr.Wizard
    Jul 20, 2014 at 7:00
  • $\begingroup$ I get the correct rendering too in V10. I'm on Windows 8.1 $\endgroup$
    – RunnyKine
    Jul 20, 2014 at 7:04
  • $\begingroup$ I'm running on OS X and it appears that a needed file /Applications/Mathematica.10.app/SystemFiles/CharacterEncodings/Webdings.m is not installed in V10. $\endgroup$
    – m_goldberg
    Jul 20, 2014 at 8:27
  • $\begingroup$ @m_goldberg What is (was) the content of that file in other versions? $\endgroup$
    – Mr.Wizard
    Jul 20, 2014 at 8:43
  • 2
    $\begingroup$ A side note: Unicode is supposed to supersede Webdings. For specific glyphs you need there are #25B8 and #25BE, correspondingly \[RightPointer] and \[DownPointer] in Mathematica. $\endgroup$
    – kirma
    Jul 20, 2014 at 9:40

2 Answers 2


Wolfram has confirmed this is a bug


I'm running of OS X, and if I try

 Style[FromCharacterCode[6, "Webdings"], 24]

I get

Get::noopen: "Cannot open /Applications/Mathematica.10.app/SystemFiles/CharacterEncodings/Webdings.m. >>"

On the other hand

Style[FromCharacterCode[Range[33, 255], "ZapfDingbats"], 24]



So it appears that the Webdings font is not supported in V10. A hint that this was true was given when I typed "Webdings" into the above code -- no completion was offered for it. On the other hand, completion was offered for the supported ZapfDingbats font.

Another verification

 MemberQ[$CharacterEncodings, "Webdings"]
MemberQ[$CharacterEncodings, "ZapfDingbats"]
  • $\begingroup$ If you repeat these tests with V9 and V8 you will see that this is not the issue here. $\endgroup$ Jul 20, 2014 at 9:20
  • $\begingroup$ I thought your question was about how things work in V10. $\endgroup$
    – m_goldberg
    Jul 20, 2014 at 9:23
  • 1
    $\begingroup$ the question is about why it works in 9 but not in 10. If you repeat the tests in your answer with V8 and V9 you get the same output as with V10 when testing FromCharacterCode. V8, V9, V10 produce the same output. However my question shows that when using FontFamily the breakage is only in V10. Hence this answer does not address why it does not work in V10. $\endgroup$ Jul 20, 2014 at 9:26
  • $\begingroup$ You're right, I can't explain why. Perhaps you should ask WRI on Wolfram Community. $\endgroup$
    – m_goldberg
    Jul 20, 2014 at 9:29
  • $\begingroup$ I've sent an email to tech support 1 minute ago! $\endgroup$ Jul 20, 2014 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.