3
$\begingroup$

I performed a fresh install of Mathematica 13.2. The first code that I tried worked just fine under 13.0. It opens an SQL server connection using single sign-on (SSO) for my credentials. However, in 13.2 I got an error that I've seen many times before:

I/O Error: SSO Failed: Native SSPI library not loaded. Check the java.library.path system property.

This occurs because SSO needs the 'ntlmauth.dll' file to be installed, which doesn't come in a default Mathematica installation. This is easily solved by downloading this file from Sourceforge and installing it in Wolfram Research\Mathematica\13.2\SystemFiles\Java\Windows-x86-64\bin

Usually, I can then proceed without problems, but this time I get this error:

A Java exception occurred: java.lang.NoSuchFieldException: usr_paths

enter image description here

Anyone got a clue what to do here? The connection seems to work, regardless of this error message, but of course I don't want this error message (and I do not like the option to just throw a Quiet on it).

$\endgroup$
1

1 Answer 1

0
$\begingroup$

I haven't tried this solution yet but Wolfram provided the steps below. This won't solve the error message but at least they are working on fixing it in a future release.


Thank you for letting us know about this. The developers are working to have a fix soon. In the meantime a work around is to do the following:

ne workaround would be adding mssql authentication library location (C:\Program Files\Wolfram Research\Mathematica\13.2\SystemFiles\Links\DatabaseLink\Java\Libraries\Windows-x86-64) to "Path" system environment variable.

Steps: Go to edit the system environment Select "Path" System variables. Click edit button. Click New button. Add mssql library path 'C:\Program Files\Wolfram Research\Mathematica\13.2\SystemFiles\Links\DatabaseLink\Java\Libraries\Windows-x86-64' Click Ok -> Ok -> OK Restart mathematica

MSSQL_Library_Location: FileNameJoin[{$InstallationDirectory,"SystemFiles","Links","DatabaseLink","Java","Libraries",$SystemID}] //SystemOpen

Note: The connection with be sucessfull but there will be error message.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.