5
$\begingroup$

I tried install WolframScript to use WolframLanguage in Jupyter notebook. https://github.com/WolframResearch/WolframLanguageForJupyter

Wolfram Language kernel for Jupyter notebooks requires WolframEngine and WolframScript. WolframEngine was correctly installed. I could logged in with my wolfram ID and calculate something in Terminal.app. However, WolframScript doesn't work. It says,

The product exited during an activation attempt because an error occurred.

[Process completed]

This may also cause the error below when I run ./configure-jupyter.wls add in WolframLanguageForJupyter directory

sh: /WolframKernel: No such file or directory

It can execute only numerical calculation in Terminal and can't plot the answer. I would like to use Jupyter notebook to work Plot[].

Thank you in advance.

$\endgroup$
1
  • $\begingroup$ Welcome to Mathematica SE! For this sort of problem, you’ll likely have better luck with this on Community. $\endgroup$ Aug 20 '20 at 18:00
6
$\begingroup$

I was in trouble with my MBP too but I finally solved this problem.

Please check this site: https://support.wolfram.com/47243

and read the section "How do I specify which kernel WolframScript should use?".

Next please launch WolframScript from the command line with the command as written.

You will see the message "Configured:WOLFRAMSCRIPT_KERNELPATH=/Applications/Wolfram Engine.app/Contents/MacOS/WolframKernel" if your machine is Mac (just example).

Now you can use "wolframscript" command.

The problem was so simple I think. Only WolframEngine(kernel) asks activation, so only it knows about it. However, WolframScript needs activation too, but there is only one-time activation to avoid asking many times. Then we need to tell wolframscript where the kernel is of course.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.