5
$\begingroup$

I downloaded the latest Wolfram Engine for Developers 12.0 (Linux).

I installed it in a non-default location: /opt/Wolfram/WolframEngine/12.0/ ran wolframscript, everything worked.

Then I installed the Python client, wolframclient. I followed this example (https://reference.wolfram.com/language/WolframClientForPython/): The default session = WolframLanguageSession() gave the following exception:

>>> from wolframclient.evaluation import WolframLanguageSession
>>> from wolframclient.language import wl, wlexpr
>>> session = WolframLanguageSession()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.6/dist-packages/wolframclient/evaluation/kernel/localsession.py", line 121, in __init__
    **kwargs)
  File "/usr/local/lib/python3.6/dist-packages/wolframclient/evaluation/kernel/kernelcontroller.py", line 132, in __init__
    'Invalid kernel value. Expecting a filepath as a string.')
ValueError: Invalid kernel value. Expecting a filepath as a string.

I tried various paths for the kernel paramter, but which path? So I assumed it was because I installed it in /opt instead of /usr/local. So then I deleted /opt/Wolfram (but I forgot to delete /usr/bin/wolframscript (symbolic link)). Then I re-installed Wolfram Engine. This time the installer didn't create the WolframScript directory. The symbolic link was pointing to it before.

However I do get these executables, that when I run wolfram looks like it could have been the target of the wolframscript symbolic link.

lcordier@tardis:/usr/local/Wolfram/WolframEngine/12.0/Executables$ ls -g
total 44
-rwxr-xr-x 1 root 5085 May 25 02:44 math
-rwxr-xr-x 1 root 5085 May 25 02:44 MathKernel
-rwxr-xr-x 1 root 2024 May 25 02:44 mcc
-rwxr-xr-x 1 root 5085 May 25 02:44 wolfram
-rwxr-xr-x 1 root 5085 May 25 02:44 WolframKernel
-rwxr-xr-x 1 root 3530 May 25 02:44 wolframplayer
-rwxr-xr-x 1 root 3530 May 25 02:44 WolframPlayer

So I tried the pythonclient example again, with the same ValueError: Invalid kernel value. exception.

So as a final step, I re-installed Wolfram Engine, this time leaving the existing directories in place. The installer correctly figured out that there were directories to be overwritten and prompted me as such. But it still didn't create the WolframScript directory or made to worlramscript symbolic link. And the Python example still doesn't work. I am having no joy ;)

Regards, Louis.

$\endgroup$
  • 3
    $\begingroup$ Try using session=WolframLanguageSession('/usr/local/Wolfram/WolframEngine/12.0/Executables/WolframKernel'). This worked for me on Mac. $\endgroup$ – Leonid Shifrin May 25 at 18:07
  • $\begingroup$ Yes, thanks that worked. $\endgroup$ – lcordier May 27 at 8:15
  • $\begingroup$ I took the default installation on my iMac and ended up with the kernel in a different place. This worked for me in Python 3.7 on darwin: >>> k = "/Applications/Wolfram Engine.app/Contents/MacOS/WolframKernel" >>> session = WolframLanguageSession(k) $\endgroup$ – Steve L May 30 at 2:41
  • $\begingroup$ Leonid: If you'll put your comment in an answer I'll accept it as the answer. ;) $\endgroup$ – lcordier May 31 at 8:43
0
$\begingroup$

For Windows try:

session = WolframLanguageSession("C:\\Program Files\\Wolfram Research\\Wolfram Engine\\12.0\\WolframKernel.exe")

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.