3
$\begingroup$

So usually when you want to enter a fraction in Mathematica, you can do so by pressing "Ctrl+/". If you are on laptop with a german keyboard however, you will have to press "Ctrl+Shift+/" since you get a "/" by pressing Shift+7. This all used to work until recently it just gives me a strange spacing character, that when translated to FullForm, shows ".1f"

I am using Ubuntu 15.04 and it always worked till now, it works fine on other machines running Ubuntu and Debian with a german keyboard.

Any ideas? Changing the shortcuts should really be the last resort as I got really used to it and don't want to change it on every machine I'm using Mathematica on...

Cheers, Matthias

$\endgroup$
  • 1
    $\begingroup$ You might have a spurious key binding. Take a look at the locations for recognized key bindings mentioned here: How can I find out where a key binding is coming from?. I'd try to get in touch with support as well. $\endgroup$ – MarcoB Aug 17 '15 at 19:42
  • $\begingroup$ Checked the files mentioned there, nothing there... $\endgroup$ – Matthias Koenig Aug 17 '15 at 23:45
  • $\begingroup$ Welcome to Mathematica.SE! I hope you will become a regular contributor. To get started, 1) take the introductory Tour now, 2) when you see good questions and answers, vote them up by clicking the gray triangles, because the credibility of the system is based on the reputation gained by users sharing their knowledge, 3) remember to accept the answer, if any, that solves your problem, by clicking the checkmark sign, and 4) give help too, by answering questions in your areas of expertise. $\endgroup$ – bbgodfrey Aug 18 '15 at 2:02
  • 1
    $\begingroup$ I have exaclty the same problem with Mathematica 10.2 on Fedora 22 (64-bit). This is not a spurious key binding problem, since I also have MMA 10.0.2, 9 and 8 installed on the same system, and there everything works as it should. Switching to US English keyboard layout makes fractions work again, so this is really something related to the German layout on Linux that was introduced in MMA 10.2. $\endgroup$ – vsht Aug 18 '15 at 12:53
  • $\begingroup$ ok, I contacted support. Those guys are usually pretty quick and competent so I'm hoping this issue gets resolved. $\endgroup$ – Matthias Koenig Aug 18 '15 at 15:55
3
$\begingroup$

Fraction in KeyEventTranslations.tr modified for Version 10.2:

in /usr/local/Wolfram/Mathematica/10.2/SystemFiles/FrontEnd/TextResources/X/KeyEventTranslation.tr

    Line:  Item[KeyEvent["/", Modifiers -> {Control}], "Fraction"],
    modified as follows:
    Zeile:  Item[KeyEvent["/", Modifiers -> {Control,Shift}], "Fraction"],
$\endgroup$
  • $\begingroup$ Oh, never mind my first answer: it DOES work. What I tried was Item[KeyEvent["7", Modifiers -> {Control,Shift}], "Fraction"] which seemed to make sense. $\endgroup$ – Matthias Koenig Aug 28 '15 at 20:21
  • $\begingroup$ Works like a charm, vielen Dank! Slighly OT, but does any of you have an issue with Mathematica 10.2 (older versions are ok) on Linux, where the kernel from time to time generates almost 100% CPU load for 2-3 seconds? This seems to happen in every session, but rather randomly and without an apparent reason so that I can't really give conditions to reproduce this behavior. Not sure if it is MMA or my system (Fedora 22), which is why I'm asking it here in the comments. $\endgroup$ – vsht Sep 1 '15 at 9:39
  • $\begingroup$ @user32650 In the path it should be "KeyEventTranslations.tr" instead of "KeyEventTranslation.tr". $\endgroup$ – vsht Sep 2 '15 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.