7
$\begingroup$

Ever since upgrading to Mathematica 12.1, the keyboard shortcuts that involve the shift key -- such as control-^ (control-shift-6) for a superscript, and control-@ (control-shift-2) for a square root -- don't work. Instead, I just get a beep, and the "Why the beep?" menu command produces the explanation "You used a Command or Control key combination that is not defined to do anything."

I inspected the contents of $InstallationDirectory/SystemFiles/FrontEnd/TextResources/Macintosh/KeyEventTranslations.tr, and the shortcuts that aren't working still seem to be listed. The file contains, for example,

    Item[KeyEvent["6", Modifiers -> {Control}], "Superscript"], 
    Item[KeyEvent["Keypad6", Modifiers -> {Control}], "Superscript"], 
    Item[KeyEvent["^", Modifiers -> {Control}], "Superscript"], 

and

    Item[KeyEvent["2", Modifiers -> {Control}], "Radical"], 
    Item[KeyEvent["Keypad2", Modifiers -> {Control}], "Radical"], 
    Item[KeyEvent["@", Modifiers -> {Control}], "Radical"], 

so I have no idea what might have broken.

I'm using macOS 10.15.3 (Catalina) on a Macbook Pro.

I rely on the shifted versions (control-shift-6 instead of control-6, etc.) because at the OS level I use control-(number) shortcuts to change desktop spaces.

Any suggestions?

$\endgroup$
7
  • $\begingroup$ It hurts just to type those ctrl-shift-number combinations, but I can confirm the difference between Mathematica v12.0 and v12.1 on macOS 10.14.6. $\endgroup$
    – Chris K
    Apr 9 '20 at 2:40
  • 1
    $\begingroup$ :) Thanks. (It’s not so bad once they get into muscle memory.) $\endgroup$
    – ibeatty
    Apr 9 '20 at 2:41
  • $\begingroup$ I didn't even know they worked with the shift key pressed down. I've always done it without shift. $\endgroup$
    – QuantumDot
    Apr 9 '20 at 4:43
  • $\begingroup$ Just a weird thing.. I have Mathematica 12.1 on OSX 10.15 and after commenting out the commands you mention, like KeyEvent["2" and KeyEvent["6", they still work. It looks like Mathematica is not using only that system file for shortcuts, but loading sth else. I used (* *) like other commented lines in that file, so I wouldn't expect them to work. It's strange. Also, adding new shortcuts works with KernelExecute[..], but FrontEndExecute[..] does not work. Have you solved your problem yet? $\endgroup$
    – Vladimir
    May 9 '20 at 0:38
  • $\begingroup$ @Vladimir No solution yet. It’s a pain. $\endgroup$
    – ibeatty
    May 9 '20 at 0:40
5
$\begingroup$

Some shortcuts in KeyEventTranslations.tr started making problems with new macOS + new Mathematica.

The "non shifted" shortcuts still works only because they are also defined in MenuSetup.tr. So, you can find it and change it there. The two files are in the same directory.

Find

MenuItem["Superscript", "Superscript", MenuKey["6", Modifiers->{"Control"}]],

change to

MenuItem["Superscript", "Superscript", MenuKey["6", Modifiers->{"Control", "Shift"}]],

and

MenuItem["Radical", "Radical", MenuKey["2", Modifiers->{"Control"}]],

change to

MenuItem["Radical", "Radical", MenuKey["2", Modifiers->{"Control", "Shift"}]],
$\endgroup$
2
  • $\begingroup$ It works!! (In the process of verifying that, I discovered that the original problem does not affect my desktop iMac, only my Macbook Pro -- even though both are running the same versions of MacOS and Mathematica. In general, I've got them configured pretty darn close to identically. Odd.) $\endgroup$
    – ibeatty
    May 12 '20 at 18:16
  • $\begingroup$ Wow! It is even more mysterious than I thought. $\endgroup$
    – Vladimir
    May 12 '20 at 20:14
1
$\begingroup$

Yes, this is a collision between the Mathematica shortcut and the Mac OS level shortcut for Mission Control, which is ^6 means "Switch to Desktop 6". I don't use these Mission Control shortcuts, so I just unselected them in System Preferences, under Keyboard\Mission Control. (I unselected ^1 through ^6.)

Subscript with ^6 and Radical with ^2 then work on Mathematica again.

I'm using Mathematica 12.1 on a MacBook Pro running Mac OS 10.15.5.

$\endgroup$
1
  • $\begingroup$ I do use the Mission Control shortcuts — frequently and reflexively — which is why I need Mathematica's shift-control versions to work, and why I noticed when they stopped working. $\endgroup$
    – ibeatty
    Jun 27 '20 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.