2
$\begingroup$

I've been trying to install Wolfram Workbench 2 for a few days on a Surface Pro 3 i5 256 Mb, Windows 8.1, Mathematica 10.0.1, Java 8, without success, I'm getting a bit desperate. For the Eclipse version I've tried Kepler and Luna.

The strange thing is that it used to work on a similar configuration but with a Surface Pro 2. I've tried also the solution from Rolf Mertig on this site.

Has somebody had this problem and managed to get it running ?

The error I get is

An internal error occurred during: "Launching test.nb (1)".
java.lang.UnsatisfiedLinkError: com.wolfram.jlink.NativeLink.MLOpenString(Ljava/lang/String;[Ljava/lang/String;)J
    at com.wolfram.jlink.NativeLink.MLOpenString(Native Method)
    at com.wolfram.jlink.NativeLink.<init>(NativeLink.java:113)
    at com.wolfram.jlink.MathLinkFactory.createMathLink0(MathLinkFactory.java:263)
    at com.wolfram.jlink.MathLinkFactory.createMathLink(MathLinkFactory.java:190)
    at com.wolfram.jlink.MathLinkFactory.createKernelLink0(MathLinkFactory.java:167)
    at com.wolfram.jlink.MathLinkFactory.createKernelLink(MathLinkFactory.java:65)
    at com.wolfram.eclipse.MEET.mathlink.MathLinkInitializer.<init>(MathLinkInitializer.java:23)
    at com.wolfram.eclipse.MEET.mathlink.MathLinkInitializer.initMathLink(MathLinkInitializer.java:46)
    at com.wolfram.eclipse.MEET.launch.InterpreterLink.createInterpreterLink(InterpreterLink.java:222)
    at com.wolfram.eclipse.MEET.launch.MathematicaConsoleLaunch.launchOperation(MathematicaConsoleLaunch.java:374)
    at com.wolfram.eclipse.MEET.launch.MathematicaConsoleLaunch.launch(MathematicaConsoleLaunch.java:215)
    at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858)
    at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707)
    at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018)
    at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
$\endgroup$
  • $\begingroup$ Were you using MMA 10.0.1 on your Surface Pro 2? If not I personally wouldn't bother with WB2 for MMA 10.0.x, as they don't seem to play nice together (at least for my purpose/syntax). Might be worth trying with MMA 9.x if you haven't already. $\endgroup$ – Gordon Coale Dec 23 '14 at 10:43
  • $\begingroup$ Yes I was, and I'm using mm10's Association/Dataset, so I need mm10. $\endgroup$ – faysou Dec 23 '14 at 10:56
  • 1
    $\begingroup$ @faysou you could try contacting support and asking for the Workbench 3.0 beta. This issue should be fixed in WB3.0. $\endgroup$ – Stefan R Dec 23 '14 at 21:38
2
$\begingroup$

I don't normally use Workbench, but I am pretty certain you can resolve the issue by just installing v9.

M- 10 on Windows changed a number of things under the hood.

$\endgroup$
  • $\begingroup$ Hi! Welcome to Mathematica.SE. This seems more appropriate as a comment than an answer, since it does not really answer the question of how to set up WB2 with V10 or whether it is possible. $\endgroup$ – Michael E2 Dec 23 '14 at 14:29
  • $\begingroup$ Any other answer is something I would tell tech support not to suggest. That doesn't preclude them from using v10 afterwards. $\endgroup$ – ihojnicki Dec 23 '14 at 15:01
  • $\begingroup$ It worked like a charm thank you very much for you help. $\endgroup$ – faysou Dec 23 '14 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.