7
$\begingroup$

My old installation of Workbench went inexplicably wrong, so I tried a fresh install of Eclipse & Workbench. Looks good until I try Documentation Build, when I get the following error:

An internal error occurred during: "Launching EcoEvo Paclet Build". java.lang.NullPointerException

I also tried starting a new project and got a different error on Documentation Build:

Specified VM install type does not exist: org.eclipse.jdt.internal.launching.macosx.MacOSXType

Any ideas?

Eclipse Version 2018-12 (4.10), Workbench Version 10.1.822, Mathematica Version 11.3, MacOS Version 10.14.3.

$\endgroup$
  • $\begingroup$ My biggest frustration with Workbench is that is fails unpredictably. I remember creating a project, doc build failed. I created another project with the exact same steps, then it worked ... I don't know if this is related to the problem you ran into, just mentioning that similar things happened to me too. $\endgroup$ – Szabolcs Mar 19 at 8:24
  • $\begingroup$ I have observed that Workbench is less prone to errors when using java 8 (which is the same as 1.8) rather than the latest SDK. Try using java SDK 8 (1.8) but make sure that it is this version of SDK that is actually being used. I had to modify eclipse.ini for that. For me, documentation build simply didn't work at all with null reference exception before I switched to SDK 8 :) $\endgroup$ – Anton.Sakovich Mar 19 at 9:02
  • $\begingroup$ @Anton.Sakovich Thanks for the idea, but switching to JDK1.8 didn't help. $\endgroup$ – Chris K Mar 19 at 9:11
  • $\begingroup$ I am happier since I abandoned WWB. I don't need to create docs but I imagine it is less painful to cook something up with all alternatives people posted around. $\endgroup$ – Kuba Mar 19 at 10:47
  • $\begingroup$ @Kuba I use it solely for creating documentation. If I were starting from scratch, I'd try something else for sure! $\endgroup$ – Chris K Mar 19 at 10:50
6
$\begingroup$

I solved the second problem by installing a JRE into Eclipse as described here.

I solved the first problem by re-reinstalling Eclipse. Not sure what changed -- maybe I was more careful in eliminating remnants of the previous install (.metadata folders)? maybe I used the right workspace directory? We may never know!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.