5
$\begingroup$

For some reason when you run Math.exe form windows command line, Mathematica disables the AltGr key. This is a bit annoying since my keyboard locale has the keys [, ], {, }, @, $, \, | located under this key. This makes Mathematica unusable for many novice users.

Is there a way to workaround this problem other than switching the keyboard locale? I can switch to US keyboard but my students can not since they have hard enough time finding characters that are typed on the keyboard. Is it possible to get AltGr key to work in Math.exe?

$\endgroup$
  • $\begingroup$ Are you sure Mathematica is doing this and not Windows? And if you need Math.exe can't you just write a script in a text editor such as notepad? $\endgroup$ – Sjoerd C. de Vries Apr 12 '14 at 7:32
  • $\begingroup$ @SjoerdC.deVries Yes, I'm sure mathematica is doing this! Simply put if i try to type [ in the command window before starting math.exe, no problems once I stop math.exe no problems then either. Seems pretty conclusive to me. Sure i can make a script but the entire idea hinges on interactive access. Small things like this kills big sections of my entire teaching argument. Sure i could also use Linux, but again there goes the argument. Seems pretty evident that Mathematica is continue being a second class tool at our university. $\endgroup$ – joojaa Apr 12 '14 at 9:10
  • 1
    $\begingroup$ Happens on my PC too, only in math.exe, not in other console processes. It seems to ignore num-block keys, too, even if num-lock is on. I'd say math.exe is completely unusable (interactively) with a non-us keyboard. Dumb question: Why use the console interface in the first place? Why not use the more comfortable notepad interface? $\endgroup$ – Niki Estner Apr 12 '14 at 11:33
8
$\begingroup$

Try turning off the "terminal input" system, based on GNU Readline, that was added to math.exe in version 9. Windows has its own terminal input system that works just fine.

You can disable the new "terminal input" by running math.exe with the option -rawterm.

You can also disable the new "terminal input" permanently by going to the subdirectories

Program Files/Wolfram Research/Mathematica/9.0/SystemFiles/Kernel/Binaries/Windows
Program Files/Wolfram Research/Mathematica/9.0/SystemFiles/Kernel/Binaries/Windows-x86-64

or

Program Files/Wolfram Research/Mathematica/10.0/SystemFiles/Libraries/Windows
Program Files/Wolfram Research/Mathematica/10.0/SystemFiles/Libraries/Windows-x86-64

and renaming the files term.dll to something else, like term.dll.goaway

$\endgroup$
  • 1
    $\begingroup$ I can not get the -rawterm flag to work. However disabling the dll does work. LOL, the IT department is going to have a fit :) $\endgroup$ – joojaa Apr 13 '14 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.