11
$\begingroup$

In Wolfram Workbench it used to be possible to generate HTML Documentation pages. Now when I build, using Mathematica 10.4+ and Workbench 2 or 3 on Windows 8.1, the HTML build fails (the notebook documentation build still works).

The error I receive in the AntLog is: *** Output file test failed ***. Which means that the HTML files are not Exported.

Tracing a bit further in ExportDocumentation I found the function Transmogrify, which should have exported the HTML but does not.

$\endgroup$
  • 1
    $\begingroup$ I just tried it and it worked for me: Mathematica 11.0.1, MacOS 10.12, Wolfram Workbench 10.1.755, Eclipse Neon.1 Release (4.6.1). $\endgroup$ – Chris K Oct 13 '16 at 14:28
  • $\begingroup$ @ChrisK, Thanks for checking. I will try the Eclipse plugin. $\endgroup$ – Frank Martin Oct 14 '16 at 9:29
9
$\begingroup$

Partial Solution

Wolfram Workbench 2 and 3 are not able to launch the front end (Mathematica 10+) to create the final HTML. The solution is to use the new (Eclipse-plugin) version, downloadable from: https://www.wolfram.com/workbench/. Which is also free when you have purchased a Mathematica license.

Some issues with the HTML

edit: I took the time to document the steps bellow in more detail here.

I encountered some issues with the generated HTML (my best guess is that the HTML for local viewing, as Wolfram is calling it, is not updated). Not sure if I fixed this in the right place, so please if you have a better solution let me know. These fixes should be done in the

  • in fonts.css (either in the minimal or standard folder) the font SourceSansPro-Semibold.woff seems to have an incorrect path replace all: /fonts/sourcesanspro/v8/fonts/SourceSansPro with /fonts/sourcesanspro/v8/SourceSansPro
  • the folder: images/mathematicaIncludes does not seem to be copied for local viewing.
  • It is not possible to click to code to copy (like on the Mathematica site). Change the jquery version to 1.7.2 (already in the export), and add the clipboards.js from Wolfram: http://reference.wolfram.com/2013/javascript/clipboard.js, The styling can be fixed by: http://reference.wolfram.com/2013/css/clipboard.css. Don't forget to also include the two images: http://reference.wolfram.com/2013/images/clipboard@2x.png and http://reference.wolfram.com/2013/images/check-mark@2x.png
  • The collapsed pages (like Scope and options) do not show the code sniplets but the text Click code to copy. Apparently the sub-pages.js is outdated, i looked up which they used on their site: http://reference.wolfram.com/2013/javascript/sub-pages.js. This fixes the problem.
  • Links on the top right corner (see also) relative path is not correct, leading to a dead page.
$\endgroup$
  • $\begingroup$ Hi @Frank did you ever get this to work? I'm on workbench eclipse plugin 10.1.757 and still see every single issue you mention and more... $\endgroup$ – M.R. Dec 21 '16 at 5:04
  • 1
    $\begingroup$ @M.R. yes it worked fine. You can see that it worked at: lieanalysis.nl/documentation . I geuss i will be updating this answer soon with some new insights. If you encounter any difficulties I be happy to help. $\endgroup$ – Frank Martin Dec 21 '16 at 9:10
  • $\begingroup$ @M.R. Not that the link in previous comment is a work in progress ;) $\endgroup$ – Frank Martin Dec 21 '16 at 9:11
  • 2
    $\begingroup$ I checked out your site, very nice. I would love to know how you overcame all the issues in the html build process and maybe wrap it into a git repo. Perhaps we can have a chat session if you have a free moment. I added pictures of the problems I see while exporting below. $\endgroup$ – M.R. Dec 21 '16 at 17:23
  • $\begingroup$ How do you "change the version of jquery" btw? $\endgroup$ – user5601 Dec 21 '16 at 17:37
2
$\begingroup$

This is not an answer but an extended comment. I'm on macos 10.12.1 with v11.0.1 and I'm using this version of the eclipse (for java developers) wolfram plugin:

enter image description here

I wanted to put up pictures of all the glitches from the html export process:

  • Corrupted input cells:

    enter image description here

  • Corrupted input and output cells:

    enter image description here

  • Missing input cells:

    enter image description here

  • Arrows not formatting:

    enter image description here

  • Broken extended examples sections:

    enter image description here


  • Frank Martin was able to get this click to copy button working:

    enter image description here

$\endgroup$
  • 1
    $\begingroup$ I wonder if wolfram has a newer version of DocumentationBuild/Tools, Transmogrify, and html.xml and hasn't released it? $\endgroup$ – M.R. Dec 21 '16 at 17:16
  • $\begingroup$ The html.xml build script references MMA6: <property name="mathExe" value="C:\\Program\ Files\\Wolfram\ Research\\Mathematica\\6.0\\MathKernel.exe"/> There must be a new version somewhere no? $\endgroup$ – user5601 Dec 21 '16 at 18:09
  • $\begingroup$ Some of these issues are related to the javascript, ill update this post early next year. $\endgroup$ – Frank Martin Dec 22 '16 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.