7
$\begingroup$

I have some problems with my mathematica 10 on Ubuntu 12.04. First, the keyboard input is extremely slow. I press a key, and then the input comes with a delay. This makes typing very cumbersome.

However, this is not the biggest issue. After a short while, my keyboard goes mad and the keys get shuffled around, so sometimes when I press a key, I get a different input (however, the delay issue is now gone...). Some examples, now every 4th keystroke I get "g" for ~4 keystrokes, no matter which key I press. Another time, every ~8 letter keystroke was ignored, while every ~4th arrow keystroke gave an "s". It is completely absurd. The "random input" seems to depend on what I previously typed, in some way. I tried to upgrade from Mathematica 10.1 to 10.2, but no improvement.

Anyone has similar issues?

$\endgroup$
  • 1
    $\begingroup$ Jon, perhaps try a clean start as described here: mathematica.stackexchange.com/a/91995/27951 $\endgroup$ – MarcoB Aug 31 '15 at 20:46
  • 1
    $\begingroup$ If this still happens after a clean start as suggested by @MarcoB, you could see if turning off the code completion helps you, by evaluating this piece of code: SetOptions[$FrontEnd, CodeAssistOptions -> {"AutoPopupEnable" -> False}] $\endgroup$ – Arnoud Buzing Aug 31 '15 at 21:56
  • 2
    $\begingroup$ None of these fixes worked. It seems like the problem does not happen if I have an empty document, only if I have some code written in the document. $\endgroup$ – Jonathan Lindgren Sep 1 '15 at 9:17
  • 3
    $\begingroup$ I can only say that I got exactly the same problem with Mathematica 10.1 and Ubuntu 14.04.3 LTS. Even the thing that everythings seems to work ok on an empty document. No solution found yet.. $\endgroup$ – user32789 Sep 3 '15 at 7:04
  • $\begingroup$ Same problem with Mathematica 11.0 and Ubuntu 16.04 LTS $\endgroup$ – Jan M. Feb 21 '17 at 9:51
3
$\begingroup$

This will sound ridiculous, but try copying something to the clipboard (need not be from within Mathematica). Bizarrely, this fixed sluggish Mathematica behavior for me.

In more detail, I was experiencing the following under a KDE-based Linux:

  • Logout, login, launch M11: it pauses a long time at splash graphics with the "initializing kernels" message, afterwards is sluggish responding to user input. Quit M11, launch M10, same pause and sluggish behavior there as well. Quit M10. But now, future launches of either M11 or M10 exhibit no problems (until the next time you logout).
  • Logout, login, launch M10, no problems, and can also launch M11 afterwards, no problems.
  • In the first situation, whether it is M11 or M10 (or both) being sluggish, if you go to any window (need not be Mathematica) and COPY anything to the clipboard, instantaneously already-running (and future launched) M10/M11 stop being sluggish.
  • Logout, login, COPY anything to the clipboard, now launch M11, no problem.

KDE has a system component called Klipper that remembers historical clipboard entries. It seems M11 goes crazy (and puts the system in a state that makes M10 go crazy) under precisely the following circumstance (which is the typical circumstance after logging in):

Klipper running with past history but nothing on the clipboard in current session, and M10 has never run and quit in current session.

  • If Klipper isn't running at all, you're fine.
  • If Klipper launches with empty history, you're fine.
  • If Klipper launches with history, and you click Klipper to put a historical entry on the active clipboard, or copy something to the clipboard, you're fine.
  • More mysteriously, if M10 has run and exited, you'll also be fine.

You don't have to logout to reproduce the issue. Just quit Klipper, restart Klipper, and launch M11.

Workarounds:

  1. configure Klipper to not remember history (across logout/login);
  2. or copy something to the clipboard before launching M11.
$\endgroup$
2
$\begingroup$

Think this is a problem with Unity, try switching to Gnome (seems to have fixed it for me).

http://www.howtogeek.com/189912/how-to-install-the-gnome-classic-desktop-in-ubuntu-14.04/

$\endgroup$
  • 1
    $\begingroup$ I'm having the same issue with Mathematica 10.4.1 on Ubuntu 14.04 running Gnome flashback. $\endgroup$ – mikemtnbikes Aug 7 '16 at 16:11
  • $\begingroup$ Same issue on 16.04LTS, Mathematica 11.0 $\endgroup$ – Jan M. Feb 21 '17 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.