5
$\begingroup$

I am using Mathematica 10.0.2.0 on a Mac OS X (Yosemite v. 10.10.1, 64bit).

After I call:

Needs["PlotLegends`"]

I get the info:

General::obspkg: PlotLegends` is now obsolete. The legacy version being loaded may conflict with current functionality. See the Compatibility Guide for updating information.

What is meant by: "PlotLegends` is now obsolete"?

All the PlotLegends related keyword are nevertheless working.

$\endgroup$
10
$\begingroup$

You should use built-in option PlotLegends now (note the s in the end). From MathGroup archive:

WRI forgot to change the documentation PlotLegends/guide/PlotLegendsPackage so as to say it's obsolete and to refer to the new PlotLegends built into the kernel.

$\endgroup$
  • $\begingroup$ The answer currently suggests that all the functionality in the PlotLegends` package can be recreated using the PlotLegends option. It seems to me that it is not possible to create reasonable legends for a Show of a Plot and a ListPlot using this option however. Is this correct? It would seem something like Legended is needed. $\endgroup$ – Jacob Akkerboom Nov 30 '15 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.