1
$\begingroup$

I'm trying to print Mathematica code (no figures) that is often much wider than a typical 9x11 page. Printing to PDF or XPS or any type of file cuts of the edges. I can select "Print Multiple pages for wide cells" in the print options menu which words but this is practically impossible to use in any meaningful way. I also tried .html which seemed promising but this never "printed" the whole document. It would print maybe a 1/3 to a half of the code and then end. Does anyone have a good solution for this?

10 minutes of Googling didn't find me an answer although I feel like this must have been asked previously. I also didn't get anything helpful from the printing tag.

$\endgroup$
  • $\begingroup$ I'm on my phone so someone will follow up with the exact option but it sounds like you need to set the page wrapping to page width. You can set this from the menu or manually set it and then add to a stylesheet $\endgroup$ – Mike Honeychurch Dec 12 '14 at 22:17
  • $\begingroup$ Or try printing to paper in landscape (rather than portrait) orientation. $\endgroup$ – David G. Stork Dec 13 '14 at 5:49
  • $\begingroup$ Landscape helps but still quite a bit of code gets cut off. With page wrapping on or off only seems to effect text not actual code. $\endgroup$ – Nick Jan 5 '15 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.