6
$\begingroup$

Printing from either 10.2.0 or 10.1.0, or any other print related function (Print Preview, Save as PDF) crash my Mathematica instantly. I've tried all the usual stuff like reinstalling, deleting user preferences and even all the system level files in /Library.

Seems like this is probably related to OS X 10.11. I've contacted Wolfram Tech Support about this issue but wondering if any others have experienced this?

I found the following issue which seemed vaguely similar: Front end crash on Export in 10.2 on OS X. I am able to reproduce that problem with 10.2.0, not with 10.1.0.

My only workaround right now is to paste the code into my notebook using a reinstalled version of Mathematica 10.1.0.

Export["fileName.pdf", EvaluationNotebook[]]

Does anyone have a better solution or is it simply a bug to be squashed?

$\endgroup$
  • $\begingroup$ Welcome to Mathematica.SE! I hope you will become a regular contributor. To get started, 1) take the introductory tour now, 2) when you see good questions and answers, vote them up by clicking the gray triangles, because the credibility of the system is based on the reputation gained by users sharing their knowledge, 3) remember to accept the answer, if any, that solves your problem, by clicking the checkmark sign, and 4) give help too, by answering questions in your areas of expertise. $\endgroup$ – bbgodfrey Oct 14 '15 at 1:09
  • $\begingroup$ For completeness, maybe you could note the Case number of the report, too. I do that just to remind myself what has been reported when... the bug reporting with Wolfram is unfortunately very opaque. BTW, my latest PDF export related bug report was sent September 14 and acknowledged as a bug just on October 9 (case 3422830). So patience may be needed... I can't test this one because I'm not on the latest OS X. $\endgroup$ – Jens Oct 14 '15 at 2:49
  • $\begingroup$ With 10.2 running on OS 10.11, I haven't had a problem with Print... | Save As PDF... but sometimes get a crash with File | Save As... | Format: PDF Document (*.pdf). Does the printer that you use have a print driver? If so, have you checked for an update? $\endgroup$ – Bob Hanlon Oct 14 '15 at 3:57
  • $\begingroup$ Make sure you send an example nb that demonstrates the problem to Wolfram Tech Support, if you have not done so already. Also full info on your OS. $\endgroup$ – Daniel Lichtblau Oct 14 '15 at 14:08
  • $\begingroup$ Turned out to be something with the printer driver, as changing to a different printer worked. Thanks for the suggestion, @bob. $\endgroup$ – kahliburke Oct 14 '15 at 20:23
4
$\begingroup$

Bob Hanlon's suggestion to check print drivers helped me out.

I changed to a different printer and the crashing stopped. I had printed with this same driver through other applications without any issue and had also printed successfully to that printer from Mathematica in OS X 10.10, so there must be some interaction between the print system in OS X 10.11, this particular printer driver, and Mathematica's use of the print system.

I'll update the case (#3444472) with Wolfram.

$\endgroup$
0
$\begingroup$

I have the same problem saving/printing PDF but not whit EPS. In this case, one solution is very simple:

Save the image as EPS, then save the EPS file as PDF. The quality is even better than if we save the image in PDF directly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.