1
$\begingroup$

I ran EmbedCode[CloudDeploy[Manipulate[Plot[Sin[x + c], {x, -6, 6}], {c, -1, 1}]]] based on this instruction and obtained the html code for embedding as below:-

<!DOCTYPE html>
<html>
<body>
<iframe src="https://www.wolframcloud.com/objects/15ac46d4-e6db-43fd-b888-8bfe57b19e9a?_embed=iframe" width="600" height="800"></iframe>
</body>
</html>

And then I pasted the above html code in the Tryit Editor of w3schools, but the Manipulate doesn't show.

And then I tried to paste the code to Wordpress and Google Sites, but also don't work for these two sites.

Is there a way to run this in either Wordpress or Google site? Are there any requirements I (or the website) need to fulfill so that the Manipulate can run?

Many thanks!

$\endgroup$
  • $\begingroup$ Do you mean that 403 appears? If so then add Permissions -> "Public" to CloudDeploy. It works for me. $\endgroup$ – Kuba Apr 30 at 6:30
  • $\begingroup$ Thanks for your reply. With Permissions -> "Public", for me, it still don't work on Wordpress and Google site... $\endgroup$ – H42 Apr 30 at 21:00
  • $\begingroup$ Elaborate on "still does not work". $\endgroup$ – Kuba Apr 30 at 21:12
  • $\begingroup$ In wordpress, after pasting the code, the manipulate appears in the draft after pasting the code, but all respective html code would disappear whenever the post is published. In google site, whenever I paste the code, I got Code:30e552b and Error:Client Error. I tried to Google 30e552b to understand what it is but have no result. $\endgroup$ – H42 Apr 30 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.