Version 11.1 now shows a little grayed out × (a multiplication sign) when one is editing something, to warn them that the expression will be interpreted as the multiplication of what precedes and follows the sign. However, one is still typing, and there is no need to warn one in the middle of typing before they are finished!

This is all good and well for some, but I find it very annoying and distracting when I keep seeing this × popup in the middle of coding. Too many things already pop-up when typing and I do not need one more thing. I am not sure what to search for in the options inspector to disable this.

Mathematica graphics

  b, (*removing the , makes the x show up *)

Is there an option to remove it? Here is a small movie showing it:


Another example:

another demonstration

  • 7
    $\begingroup$ "to warn them that the syntax as it stands is not valid" - rather than that, I think that's a multiplication sign, as in the front end thinks you're multiplying b with {i, 1, n}. $\endgroup$ Commented Mar 21, 2017 at 4:59
  • 1
    $\begingroup$ @J.M. sure, I understand that. But either way, I'd like not to see it if possible. Thanks. $\endgroup$
    – Nasser
    Commented Mar 21, 2017 at 5:02
  • 12
    $\begingroup$ I like this indicator a lot. :) $\endgroup$
    – Kuba
    Commented Mar 21, 2017 at 5:53
  • 3
    $\begingroup$ Also, I don't think "to warn that syntax is not valid" is really correct; quite the contrary, it just warns that this will be parsed as an expression with head Times, so I reworded the first paragraph. Feel free to roll back if you do not like it. $\endgroup$
    – LLlAMnYP
    Commented Mar 21, 2017 at 11:03
  • 3
    $\begingroup$ I think that the warning that Times will be the default operator is good. The issue I have is the following. If the cursor is moved away from the "x" , it is very difficult to get back to that point with a mouse click. Clicking on the "x" puts the cursor at outermost closing bracket, e.g. the end of a function. Has anyone else seen this? $\endgroup$
    – John McGee
    Commented Mar 31, 2017 at 15:48

1 Answer 1


Thanks to the hint by Jason. It is called AutoMultiplicationSymbol. It can be turned off in the Option Inspector:

Mathematica graphics

It worked. Now × does not show up. Version 11.1 on windows 7.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.