14
$\begingroup$

Bug introduced in V10.0.0 or earlier and persisting through V12.0


Let's create an example and do the test:

CreateDocument[{},  InputAliases -> {"[" -> 
RowBox[{"\[LeftDoubleBracket]", "\[SelectionPlaceholder]", "\[RightDoubleBracket]"}]}]

enter image description here

As you can see this is not what I expected. SelectionPlacholder has changed to Placeholder.

OS: Win7

Can you reproduce the problem? It is not only the case of custom aliases but each built-in behaves the same...

$\endgroup$
  • 1
    $\begingroup$ I get this in v8 Linux too. $\endgroup$ – Öskå Jul 24 '14 at 9:19
  • 2
    $\begingroup$ I get "\[Placeholder]" both in v.8.0.4 and 10.0.0 under Win7 x64. But in v.8.0.4 the placeholder is selected while in v.10.0.0 it is not selected and when I type the text is inserted to the right of the placeholder. $\endgroup$ – Alexey Popkov Jul 24 '14 at 10:02
  • 2
    $\begingroup$ I was just about to post a similar question regarding the fact that \[SelectionPlaceholder]s generated by input aliases are no longer selected in v10 (Mac OS X 10.9.4) but, for example, if I create an indefinite integral "template" using the typesetting palette button (equivalent to the intt input alias) the first placeholder is selected. $\endgroup$ – MikeLimaOscar Jul 24 '14 at 10:39
  • 2
    $\begingroup$ I really hoped that after the function explosion of v10 that v11 would be a stability and performance release. I am starting to think that will never come. $\endgroup$ – Mr.Wizard Aug 9 '16 at 20:57
  • 1
    $\begingroup$ @Mr.Wizard at least it seems to be the best x.0.0 for a long time. $\endgroup$ – Kuba Aug 9 '16 at 21:12