1
$\begingroup$

I tried (foolhardily, it appears) installing macOS Mojave Version10.4 on my MacBookAir, but encountered major problems--that seemed to have been (finally) fixed after a reinstallation and reloading of disk contents. But then when I tried running a Mathematica program, previously run many times, I encountered a new set of errors I had never seen before, that is:

CCompilerDriver`CreateLibrary::cmperr: Compile error: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Compile::nogen: A library could not be generated from the compiled function.

Perhaps I should contact Wolfram Support, and ask for a new copy of Mathematica Version 11.3.0.0 to install.

$\endgroup$
  • 3
    $\begingroup$ Very likely this can be solved by: 1. Installing Xcode 2. Starting Xcode, and when it prompts to install command line tools, agreeing to that 3. When all this is done, restart Mathematica. Let me know if this worked. $\endgroup$ – Szabolcs Oct 26 '18 at 16:07
  • $\begingroup$ I do think this is a question that should be addressed by Wolfram Customer Support, and is unlikely to help any future visitors. $\endgroup$ – rhermans Oct 26 '18 at 16:07
  • $\begingroup$ A macOS upgrade typically requires a new Xcode installation, and then a new command line tools installation. This last one is a guess, but it may also be necessary to accept the license for the command line tools. From a terminal, run sudo xcodebuild -license (only after steps 1 and 2 from above are done) $\endgroup$ – Szabolcs Oct 26 '18 at 16:09
  • $\begingroup$ Thanks Szabolcs--I'll ask my Institute staff to pursue this Xcode approach later today. I'll certainly provide updates on any progress (or hopefully not lack thereof). $\endgroup$ – Paul B. Slater Oct 26 '18 at 16:12
  • 1
    $\begingroup$ I'd note that I had this same issue when installing the mac Developer Tools, but @Szabolcs solution of running sudo xcodebuild -license worked. $\endgroup$ – KraZug Jan 9 at 14:41
3
$\begingroup$

Yes, the suggestion of Szabolics to install Xcode worked immediately, with no apparent complications/issues. Upon simply restarting Mathematica (without any "clean start"), the indicated compile errors were absent.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.