Import: Version 11.2 works correctly, no problem with non-ASCII characters in the path of file. But upgrated version 11.3

a) does not import these files

b) reports an error Import::fmterr: Cannot import data as XLSX format (i.e. unclear problem report, no "non--ASCII characters" or some similar)

How to fix this problem, with respect to previous functionality?

EDIT: This is for 11.3 while the previous question was wrt an unrelated issue in 10.0

  • 2
    $\begingroup$ See also mathematica.stackexchange.com/q/143953/12 $\endgroup$
    – Szabolcs
    Commented Oct 25, 2018 at 18:16
  • $\begingroup$ Your question may be put on-hold because it may be considered a duplicate and therefore off-topic. Please edit your question if you consider this is a mistake and give great emphasis in what was NOT answered in the other question. Please don't be discouraged by that cleaning-up policy. Your questions are and will be most welcomed. $\endgroup$
    – rhermans
    Commented Oct 26, 2018 at 15:14
  • 1
    $\begingroup$ Brilliant general solutions in mathematica.stackexchange.com/questions/143953/… I know that I searched for solutions in March but I missed this one. I think it has to do with that it worked in 11.2 and then stopped working in 11.3. Importing from files is an important use case - should be developed and tested with higher attention at WRI. $\endgroup$
    – FredrikD
    Commented Oct 26, 2018 at 15:55
  • $\begingroup$ @rhermans To be fair, these posts had two completely different answers. The previous post was solved by upgrading to 10.0.2, and was a different Unicode xls/xlsx bug. This is a new incantation of a similar bug but, and DataLegacy was only introduced in 11.3, the version this question was asking about and received new information for. I realize this probably wasn't immediately obvious without knowing about the implementation update. $\endgroup$ Commented Nov 9, 2018 at 21:33

1 Answer 1


The defect is known since March 2018. According to the support, it will be addressed in future versions (perhaps the next one - my guess).

If you want to use the legacy converter:

Import["fö.xlsx", {"DataLegacy"}]


Import["fö.xlsx", {"SheetsLegacy"}]

For me, the new import functionality seemed to be better so I changed the paths & filenames instead

  • $\begingroup$ Seems like this is fixed in v12. Tested with exporting and importing a file with "ö" in its name $\endgroup$
    – FredrikD
    Commented Apr 18, 2019 at 12:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.