3
$\begingroup$

How can I turn on antialiasing on 3D graphics from Plot3D[]? 2D graphics are antialiased for me but 3D graphics are very aliased and ugly looking, especially the coordinate axes.

I have seen people mentioning that your GPU must be powerful enough to enable antialiasing, but I have a very powerful GPU (Quadro M4000) and I can't even find the setting to enable it.

$\endgroup$
2
  • 1
    $\begingroup$ Can you check the Edit > Preferences menu item, and then look at the Appearance tab and the Graphics tab under it? You should see something like this. $\endgroup$
    – J. M.'s torpor
    Dec 14 '16 at 4:29
  • $\begingroup$ @J.M. That worked, thanks! Now I feel real dumb for not being able to find that. If u add that in an answer I'll accept it. $\endgroup$
    – PGmath
    Dec 14 '16 at 4:36
2
$\begingroup$

The Antialiasing option of Style only affects 2D graphics. For 3D plots the setting is global. To alter it, in the Mathematica Notebook menu choose EditPreferences, in dialog that appears go to Appearance tab, there to Graphics nested tab. Then move the slider to choose the amount of antialiasing.

enter image description here

$\endgroup$
1
$\begingroup$

You can use the antialiasing function to smooth your renderings. See the examples below:

enter image description here

$\endgroup$
1
  • 2
    $\begingroup$ This only works for 2D graphics, and has no effect on 3D plots. $\endgroup$
    – Ruslan
    Jul 26 '20 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.