4
$\begingroup$

When I go to the pull-down options for “File”, one of them is “Open Recent”. It lists the last 15 notebooks opened.

Is their any procedure to follow to get more (than 15) of the latest opened notebooks?

That is, something akin to “Show History” in a browser (like Safari).

$\endgroup$
  • 4
    $\begingroup$ The front end option "NotebooksMenuHistoryLength" controls the length of your history; in your case, it seems to be set to 15, so the other older notebooks you opened have already been forgotten. You could do something like SetOptions[$FrontEnd, "NotebooksMenuHistoryLength" -> 20] if you need a longer history record. $\endgroup$ – J. M.'s technical difficulties Jun 18 '16 at 17:09
  • 2
    $\begingroup$ Mathematica | Preferences ... | Advanced | Open Option Inspector | Global Options | Menu Settings | NotebooksMenuHistoryLength or at Open Option Inspector search for history $\endgroup$ – Bob Hanlon Jun 18 '16 at 18:35
7
$\begingroup$

As commented by J. M. you can persistently increase the menu size with:

SetOptions[$FrontEnd, "NotebooksMenuHistoryLength" -> 20]   (* 20 is arbitrary *)

You can extract a list of Notebook locations with:

NotebooksMenu /. Options[$FrontEnd] // MapAt[ToFileName @@ #[[1, ;; 2]] &, {All, 2}]
$\endgroup$
  • $\begingroup$ Tried the suggested SetOptions[$FrontEnd, "NotebooksMenuHistoryLength" -> 20], but didn't seem to "take". Something more to do than just simply issuing this command? $\endgroup$ – Paul B. Slater Jun 22 '16 at 21:01
  • $\begingroup$ @Paul Did you restart the Front End? If so and it still didn't work I'll need to look at this again. Which OS and Mathematica revision are you using? $\endgroup$ – Mr.Wizard Jun 23 '16 at 11:09
  • $\begingroup$ No, sorry, didn't restart FrontEnd. May I naively ask what would be involved--quitting kernel,...? I'm using "10.2.0 for Mac OS X x86 (64-bit) (July 7, 2015)" $\endgroup$ – Paul B. Slater Jun 23 '16 at 17:40
  • $\begingroup$ @Paul I just mean fully closing and reopening Mathematica, nothing unusual. If that did/does not work there may be a hard upper limit to the history length, as I don't believe I have ever kept one that long. $\endgroup$ – Mr.Wizard Jun 23 '16 at 20:47
  • 1
    $\begingroup$ @Paul Well yes, I agree with what he wrote, and since it was already written I did not repeat it. I assumed you opened additional Notebooks after increasing the history length to check if it worked. $\endgroup$ – Mr.Wizard Jun 24 '16 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.