New answers tagged

2

Looks like a bug in PlotLabels to me - my guess is that when measuring the size of the label, it does not take into account how big the rendered string will be, only the raw (rather long) string. A work-around is to wrap the label in Row@{...}: Plot[30, {x, 0, 605}, PlotStyle -> {Dashed, Thick, Black}, PlotLabels -> Row@{ "\!\(\*SubsuperscriptBox[...


2

As noted in the comments, this bug appears to have been introduced in version 11.2, when they moved a lot of the plot post-processing into System`ListPlotsDump`postProcessLayout. The issue occurs because they temporarily set DisplayFunction->Identity (to prevent multiple applications of the DisplayFunction), and then the wrong DisplayFunction setting is ...


4

Update: Yet another work-around: cf = If[# > 0, Red, Green] &; data = MapIndexed[{#2[[1]], #} &, Range[-10, 10]]; ListPlot[List /@ data, PlotMarkers -> {"*", 24}, PlotStyle -> (cf /@ data[[All, 2]])] Original answer: Another work-around: Use ListPlot without the option PlotMarkers and post-process the output to replace Points with the ...


1

Happened to me on ubuntu 18.04.2, nothing worked except lock/unlock the screen and it fixes the issue.


2

According to Wolfram support this is a bug, the team knows about it, and it will be fixed in a future version.


1

The threshold of 100 bars is hard-coded in Charting`iBarChart3D. In addition to its effect on styling as in OP, it also affects tooltips and highlighting of bars. Fortunately, 100 appears only as the value of this threshold in Charting`iBarChart3D Cases[DownValues[Charting`iBarChart3D], _[___, _[___, 100, ___], ___], All] {If[System`BarChart3DDump`...


3

This appears to be an oversight in how EdgeForm[None] (the default for $\geq100$ bars) is handled when combining the different style directives for the bars1. Essentially, EdgeForm[None] overrides any explicit EdgeForm settings, which is why they are not applied in the second case (where there are $\geq100$ bars). To circumvent this, you can execute the ...


2

The format appears to be a distraction. I get a different answer on the second time I evaluate the integral. Quit[] Hold[ Integrate[Log[(Sin[k] + Sqrt[1 + Sin[k]^2])^2], {k, 0, π}]] ReleaseHold[%] (* 4 Catalan + π Log[2] *) ReleaseHold[%%] (* 4 Catalan *) $Version (* "12.0.0 for Linux x86 (64-bit) (April 7, 2019)" *)


1

Here's a Dropbox link to a notebook which should reproduce the problem Just put the cursor inside one of the Do[Print[... input cells, scroll down so that input cell and printing area is no longer in view (the further down you scroll, the better), and press Shift-Enter to evaluate the cell. You should see the notebook scroll (at least a little bit) ...


9

Please report this as a bug. A minimal example: Quiet @ Remove["System`Dump`rep$*"]; Quiet @ Remove["System`Dump`rules$*"]; Quiet @ Remove["IPOPTLink`Private`monitor$*"]; if=NDSolveValue[{f'[x]==-2x+19,f[0]==4},f,{x,5,10}]; FindMaximum[{if[x], 5<x<10}, {x, 8}]; ToExpression[Names["System`Dump`rep$*"][[-1]], InputForm, DownValues]//Short ...


2

The following code should work for not-too-big graphs: ClearAll[MyTransitiveReductionGraph]; MyTransitiveReductionGraph[g0_Graph, opt___] := Module[{g, vertices, edges, newedges, s, t}, g = TransitiveReductionGraph[g0]; vertices = VertexList[g]; edges = EdgeList[g]; newedges = Pick[edges, Table[{s, t} = List @@ x; Length[FindShortestPath[EdgeDelete[g, ...


6

It looks like Plot does not take all the styles applied via Style into account. Since it does work in principle (the dashing is applied), you can simply combine the styling directives into one using Directive. This produces the expected result: testFunc = E^((x - 2)^(3/2)/(2*Sqrt[2])); Plot[ Style[testFunc, Directive[Darker[Red], Dashed]], {x, 1, 10}, ...


Top 50 recent answers are included