2 of 2 added 73 characters in body

I ended up following the last solution suggested, that is, deleting the folder in the init file. Although it required a few minor modifications for it to work on Windows.

Specifically, Mathematica 11 on Windows 7 creates the folder MyDocuments\Wolfram Mathematica each time it starts, and I couldn't find a user-friendly way to modify or prevent this through the GUI in Preferences, which annoys the hell out of me.

As a simple workaround for Windows, consider editing


adding the command

With[{dir = $UserDocumentsDirectory <> "\\Wolfram Mathematica"}, If[DirectoryQ[dir], DeleteDirectory[dir]]]

to delete it automatically. Note the DOUBLE backslash as folder separator. Alternatively, use FileNameJoin.

Thanks to Darko Veberic for the suggestion.