Questions tagged [bugs]

This tag is reserved for questions where the problem has been vetted by this community and the observed behavior is confirmed to be a bug. Please do not use this tag for new questions. Please use the standard bugs header instead of version tags in conjunction with this tag.

Filter by
Sorted by
Tagged with
9
votes
1answer
224 views

Cannot reproduce TransformedRegion example shown in documentation

Bug introduced in 10.0.2 or earlier and fixed in 11.1.0 Note: TransformedRegion was introduced in 10.0.0. Reproducing an example from Mathematica's help, I obtain ...
8
votes
3answers
297 views

Inset in ArrayPlot

Bug introduced in 9.0 or earlier and persisting through 11.0.1 or later It seems the options in the Inset object will be ignored when passing to ...
8
votes
1answer
776 views

ErrorListPlot - Problem with PlotRange

Bug introduced in 10.4 or earlier and persisting through 12.0 Consider the following example: ...
7
votes
2answers
269 views

Taylor expansion of a function containing QPochhammer[q, q, n]

I want to get the following series expansion: Series[QPochhammer[q, q, 3], {q, 0,4}] but in Mathematica 11.0, I obtain the following gibberish: There weren't ...
7
votes
1answer
217 views

Anti-aliasing not working in Mathematica 10.3 and XUbuntu

Bug introduced in 10.0.2 on XUbuntu persisting through 10.3 or later I'm running a fresh install of XUbuntu 14.04.3 LTS with an NVidia GeForce GTX 970. I have installed NVidia driver 352.63 and ...
7
votes
3answers
224 views

1D ImplictRegion can not be plotted with RegionPlot

Bug introduced in 10.4.0 and fixed in 11.0.0 I am using Mathematica 10.4 In the documantion page of ImplicitRegion, there is an example ...
4
votes
1answer
161 views

Issue with the debug tools window [duplicate]

I have an issue with the debug tools window. It appears on its own periodically. I have turned it off in the Evaluation menu, and have gone to "Debugger Controls" and deselected "Show Debugger Tools ...
17
votes
3answers
288 views

EdgeAdd function not adding edges to a RandomGraph[ ] with no edges

Bug introduced in 9.0 or earlier, fixed in 11.3 I have a graph: g = RandomGraph[{1, 0}] So basically, it is just one vertex. I want to add some vertices and ...
15
votes
1answer
313 views

Why does ImageFilter fail with radius 1, but works with radius 2?

Bug introduced in 9 and persists through 12.0.0 When thinking on a way to answer this question using ImageFilter I have found (with Jason B's help) that we can ...
14
votes
4answers
393 views

Terrible accuracy of DawsonF

DawsonF[30.] returns 0. The correct value is 0.016676... At least it prints a warning message, ...
13
votes
6answers
574 views

Correct way to integrate a certain function

Bug introduced in 9.0 and fixed in 10.1 I want to integrate $$\int_{0}^{2\pi} dt_1 \frac{a + b\cos(t_1 - t_2)}{c + d\cos(t_1 - t_2)}$$ where $a, b, c, d, t_2$ are real numbers and $c + d > 0$ &...
12
votes
1answer
354 views

AbsoluteOptions prints error messages in V10

Bug introduced in 10.0.0 and fixed in 10.0.2 I am trying to use AbsoluteOptions in V10 but I am getting the Out with some errors as see in this picture: does anyone have same issue?
12
votes
2answers
406 views

Possible Bug in DiscretizeRegion with Option MaxCellMeasure

Bug introduced in 10.0.0 and fixed in 10.0.2 Consider the following ImplicitRegion: ...
11
votes
2answers
294 views

Probable Bug in HighlightMesh with 2D Convex Hulls created via ConvexHullMesh

Bug introduced in 10.0 and fixed in 10.2 One nice way to view the new and exciting Mesh objects introduced in Version 10 is by utilizing the function ...
10
votes
1answer
651 views

Issues with PlotRange

Bug introduced in 10.1 or earlier and persisting through 11.0.1 or later When I use the following command to plot a graph: Plot[x^Gamma[x - 1], {x, 0, 1}] or: <...
10
votes
3answers
525 views

Wrong results from NSolve on coupled polynomials. WorkingPrecision -> Automatic fails

OP UPDATE: I received an email from WR on 1-18-2016: "...It does appear that the NSolve function is not behaving properly in this case and I have forwarded an incident report to our developers with ...
9
votes
4answers
390 views

Unexpected behavior from GatherBy in version 7

Bug introduced in 7.0 or earlier and fixed in 8.0.4 or earlier I have come across what appears to be a bug in GatherBy. It appears similar to the problem of using ...
9
votes
2answers
304 views

SetOptions for CoordinatesToolOptions for DateListPlot?

Bug introduced in 10.0 and persisting through 11.0 or later DateListPlot does not respect my Options setting for ...
8
votes
1answer
258 views

Mathematica Version 11.0.1 Strange Result from NSolve (Linux)

I recently got an update to Mathematica Version 11.0.1 (Linux 3.10.0-327.36.3.el7.x86_64, RHEL 7.2, Lustre 2.5.42.8.ddn5), and run some test routines to check, if my Mathematica packages are still ...
7
votes
1answer
152 views

Error when combining Except, “*” and an additional character

Bug introduced in 5 or earlier and persists through 10.4.1 Anyone knows why ...
7
votes
1answer
266 views

A unexpected behaviour of RelationGraph

$Version "10.4.1 for Microsoft Windows (64-bit) (April 11, 2016)" I want to match the based point of VoronoiMesh(...
6
votes
0answers
175 views

Spurious DSolve Solution

Bug introduced in 8.0.4 or earlier, persisting through 12.0. DSolve quickly returns solutions to the following PDE (which is the homogeneous portion of the PDE in ...
6
votes
2answers
214 views

Why does Rotate in PlotMarkers behave strangely?

Bug introduced in 9.0 or earlier and persisting through 12.0 While answering Change the inner color of markers I came across a behavior that may be a bug. I would like to know if there is another ...
6
votes
3answers
1k views

ListPolarPlot not showing full plot range even with PlotRange -> All

Bug introduced in 8.0 and fixed in 9.0 I have a list of data dpdOt (given below) with associated angular coordinates thetaplot, ...
6
votes
0answers
302 views

Bug report: Attempting to Save Selection As… in a magnified Notebook fails with errors [duplicate]

Bug introduced in 9.0.1 or earlier and persisting through 10.0.2 or later I have found that attempting to Save Selection As... in a magnified Notebook fails with errors. On my system it can be ...
6
votes
4answers
1k views

ParametricPlot and PlotLegends don't seem to cooperate

Bug introduced in 9.0.1 -- fixed in 10.0.0? I noted that only part of the legend shows up in ParametricPlot using v9's ...
6
votes
1answer
244 views

Plot points shifted (a lot) in output and PNG export but not in PDF export

Bug introduced in 8 or earlier and fixed in 12.0.0 Consider the following code: ...
5
votes
1answer
920 views

Cannot import Excel (xls or xlsx) files which have non-ASCII characters in the name

It seems mma9 works fine, but with mma10 it fail to load a file name with Chinese characters. I use MacBook Pro(Retina) with OSX 10.10.2, and Mathematica 10.0.0.0. I need the file name with Chinese ...
4
votes
1answer
91 views

NotebookImport ignoring multiple style cells

Bug introduced in V11 or earlier and persisting through 11.3 [...] I have filed a report to the development team, raising the issue to them. [...] CASE:3802659 ...
2
votes
1answer
97 views

Numerous Extraneous Error Messages from EvaluationData

In the course of solving question 134644, I encountered the message Reduce::ztest1: Unable to decide whether numeric quantity -Log[5381171456512]+Log[(-Sqrt[101] Log2-10 Sqrt[101] Log[5]+101 (...
36
votes
2answers
963 views

Eigenvalues broken in Version 12.0

Bug introduced in 12.0. The following code calculates the eigenvalues of a certain complex matrix, which come in pairs of opposite complex numbers. Therefore one can check whether the sum of all ...
45
votes
0answers
786 views

Hyperlinks not preserved when saving in PDF format in MMA V10

Bug introduced in 10.0 or earlier and fixed in 11.0.0 I usually create my course contracts in Mathematica and then save them in PDF format. The notebooks include hyperlinks and these have ...
20
votes
2answers
564 views

How to take a subgraph of an edge-weighted graph and preserve weights?

Bug introduced in 8.0 or earlier and fixed in 12.0 I need create a weighted graph with given data. Number of nodes: $53$ $\quad$ Number of edges: $91$ ...
10
votes
2answers
474 views

Bug in NDSolve/WhenEvent?

Bug introduced in 10.3 or earlier and persisting in 11.0 10.0 is not affected I'm fairly sure the following is a bug, and I would normally just report it to WRI. However, this is related to my ...
15
votes
2answers
265 views

Bug with SparseArray selector in Pick

Bug introduced in version 8 or earlier and fixed in 10.0 I have created a notebook with two cells. This is the content of the first: ...
14
votes
4answers
1k views

DataEncoding and compression in HDF5 format

I would like to export data in HDF5 format with Mathematica 9. The Mathematica manual about Import and Export of this format can be read here. As I'm dealing with large arrays, export often lead to ...
28
votes
2answers
860 views

Default behaviour of Hash[expr] and hashing in different versions of Mathematica

In different versions of Mathematica, Wolfram silently changed the behaviour of Hash when the algorithm is not specified explicitly ...
21
votes
1answer
422 views

Bug with iterated With: Referring to function arguments invalidates previous definitions

Thank you for your report. I have forwarded your report to the appropriate team for review. - WRI ...
21
votes
5answers
688 views

HighlightGraph Problem

Bug introduced in 9.0 or earlier and fixed in 11.3 HighlightGraph does not work. ...
21
votes
5answers
4k views

Why this real integral yields imaginary results?

This integral yields -1-4Iπ/3 in Mathematica: Integrate[(y - y^2 + x - x^2 + 2*x*y)/(1 - x - y), {x,0,1}, {y, 0, 1}] Since ...
18
votes
1answer
352 views

Color degrades when using Copy As Bitmap

I have discovered a problem that affects my use of Mathematica. When I use the menu command Edit > Copy As > Bitmap the colors in the copy are subtly degraded. To make this more apparent I copied ...
17
votes
0answers
301 views

Break[] inside ColorFunction

Bug introduced in 8.0 or earlier and persisting through 11.0.1 or later ...
15
votes
3answers
347 views

Can anyone explain this strange behavior of InputForm?

Bug introduced in 3 or earlier, persisting through 12, fixed on Wolfram cloud only. In Mathematica 9.0.0, when to display the input form of two numbers, I come across maybe a puny problem. In order ...
13
votes
5answers
1k views

Gap in a continuous plot

Why do I get a gap in the plot below and how can I fix it? (If you are interested in it, you can see a new related question: How to plot an implicit value funtion, which is also a little chanlenging) ...
12
votes
5answers
977 views

PDF Export in 11.3

I have some Mathematica notebooks that have text, code, plots, and hyperlinks in some text cells. The notebooks use a custom stylesheet that I've used for a number of years. Up until version 11.3 ...
9
votes
1answer
264 views

How to unlock a stylesheet which is not needed anymore by the FrontEnd

Bug introduced in 10.3.0 or earlier and fixed in 11.1 Bug reproduced on Win but not on Mac Reply from WRI Support: [...] This indeed seems to be an issue with the Frontend on Windows and I have ...
7
votes
2answers
873 views

CUDAQ not working in Mathematica 10.2.0.0 on Windows 7 (using CUDA 7.5)

I have been trying to get CUDA to work in Mathematica for kernel development. I downloaded and installed Visual Studio 2013 Community and the latest NVIDIA developers toolkit 7.5 (in that order). ...
30
votes
3answers
617 views

Is there an issue tracker for already reported Mathematica bugs?

Since I'm working at least 50% on Linux which is probably the operating system which gets not so much attention from Wolfram, I find new bugs regularly. What bothers me the most is, that tracking a ...
20
votes
1answer
1k views

When importing GIF animation, how to find the correct list of “DisplayDurations”?

When importing GIF animations with variable frame durations, the settings for "DisplayDurations" are not recovered correctly. As an example, I'm using the movie from this earlier question: Here I'm ...
16
votes
2answers
359 views

Backslide in NSolve in V11.1?

Bug introduced in 11.1.0 and persisting through 11.1.1 In V11.1, NSolve[BesselJ[0, x] == 0 && 0 < x < 20, x] returns no solutions: But in V11.0 (...