We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [bugs]

This tag is reserved for questions where the problem has been vetted by this community and the observed behavior is confirmed to be a bug. Please do not use this tag for new questions. Please use the standard bugs header instead of version tags in conjunction with this tag.

Filter by
Sorted by
Tagged with
39
votes
7answers
1k views

How symbol lookup actually works

Bug introduced in V6 and fixed in V11.3 The behavior indeed changed but now the documentation is clear about it. This code is inconsistent with the description from Power Programming with ...
23
votes
5answers
2k views

How to get the real PlotRange using AbsoluteOptions?

Bug persisting through version 12.0.0.0 The problem in general involves the unreliable behaviour of AbsoluteOptions when option values are implicitly specified (e....
45
votes
1answer
2k views

Transferring a large amount of data in parallel calculations

Bug fixed in version 11.1 Functions like MemberQ, FreeQ, etc. no longer unpack. Yay! This question is inspired by one of @...
78
votes
2answers
20k views

Mathematica 10.0.x freezes in Initializing kernels

Bug caused by paclet update and fixed by paclet update. I updated to Windows 10 and have been running Mathematica fine on it for over a month. For some reason, it has just stopped working. I don't ...
37
votes
4answers
941 views

What is the difference between Dynamic[x] and Dynamic[ h[x] ] for DynamicModule variables?

Bug introduced in 9.0 or earlier and persisting through 12.0 In 11.3 it is even worse. An example from the accepted answer with a Slider is now broken too: ...
32
votes
2answers
2k views

Specifying non-conflicting PlotTheme options

A bug or limitation in 10.0.0 affects a few of these examples; it was resolved in 10.1.0. I am trying out Mathematica 10 on https://programming.wolframcloud.com. ...
32
votes
2answers
947 views

Graphics elements do not line up perfectly in exported PDFs

Bug introduced in version 9.0 and persisting through 10.4 Graphics elements do not always line up perfectly in exported PDFs using "Save As..." method. Take, for example: ...
22
votes
1answer
3k views

Thickness of logarithmic tick marks

Bug introduced in 8 or earlier and persisting through 12.0 I'm trying to plot a graph wit a logarithmic y-axis. Since I'm exporting the graph to pdf and later printing it, I want to manually set the ...
35
votes
2answers
4k views

Debugging memory leaks

I've written my incredibly complex, incredibly elegant analysis function, that works great on small test data. But when I run it on my real (bigger) data set it keeps running out of memory. It turns ...
13
votes
0answers
443 views

Issues adding properties to multigraph

Bug persisting through 12.0 Unsupported Functionality (loosely, a bug) Mathematica (as of 11.0.1 for Mac OS X x86 (64-bit) (September 21, 2016)) does not support multi-graph where edge properties ...
7
votes
1answer
1k views

Issue with NSolve

I defined the following function: sw[ θ_, ϕ_, h_] = 1/2 Sin[2 (ϕ - θ)] + h Sin[ϕ] Based upon whether I use Solve or NSolve, ...
23
votes
1answer
2k views

Segmentation fault on auto-complete

My front-end freezes as soon as I type more than two letters in a notebook. I think the error occurs, when the auto-complete feature kicks in. If Mathematica was started from a terminal, the following ...
19
votes
5answers
5k views

Export high resolution figure causes missing ticks

Bug persisting through 11.3 I understand that Mathematica has a bug when exporting images. The ticks are scaled not correctly when exporting at high resolution. For example: when you do: ...
21
votes
2answers
4k views

Failure to export graphics by right-click when Notebook magnification is changed

Bug introduced in 9.0.1 or earlier and persisting through 11.0.1 or later When I try to export graphics as PNG, JPG and other rasterized formats using the right-click and choosing ...
24
votes
1answer
996 views

More Ticks::ticks errors in AbsoluteOptions in v10

Bug introduced in 7.0 or earlier and persisting through 11.3 While the specific bug affecting Plot described in AbsoluteOptions prints error messages in V10 has ...
15
votes
2answers
607 views

How to workaround failures with Unicode filepaths?

(Cross-posted on the Wolfram Community, reported to the support as [CASE:3965891].) The Mathematica's Kernel and FrontEnd currently work well with Unicode file/directory paths, but some other ...
21
votes
4answers
1k views

LogPlot axes labels destroyed when working in high precision

Bug introduced in 7.0 or earlier and fixed in 11.0.0 (I'm using Mathematica 8.) I have a Taylor series: poly = Normal[Series[E^x, {x, 0, 10}]] I want to ...
28
votes
1answer
1k views

Unintended edge extensions in 3D Cube rendering

Bug introduced in 7.0.1 or earlier -- persists through 10.1.0 or later I have arranged a certain configuration of cubes in 3D using the following code: ...
3
votes
1answer
602 views

Initializing Manipulator value within DialogInput (version 10.1 only)

Bug introduced in 10.1.0 and fixed in 10.2.0 I've confirmed, with WRI, that an issue was introduced in version 10.1 with regard to initializing Manipulator Dynamic ...
38
votes
4answers
2k views

Error changing Dataset using Part

Update It was a bug in the documentation of V10.0, this functionality was not implemented yet, and V10.1 changed the documentation, removing it. It's a pity, because it's a very useful operations, ...
21
votes
1answer
540 views

Bug in Mathematica TeXForm generating \left\left

Bug introduced in 9.0 and persisting through 11.3 or later I asked about this in the TeX chat. It seems Mathematica generate invalid Latex in this example. ...
23
votes
1answer
713 views

Unwanted PlotMarkers appear at non-existent places

Bug introduced in 7.0 or earlier and persisting through 11.3 In this simple code ...
11
votes
2answers
407 views

Held keys in associations

Bug introduced in 10.0 and persisting through 11.0.1 or later Bug introduced in 10.0 and fixed in 10.4 Association is new in 10.0. Bug still present: ...
9
votes
4answers
469 views

Incompatibility of Row and TeXForm

Bug introduced in 9.0 and persisting through 11.0 Update: Since no one has been able to give a reason for this change in behavior or provide a solution I am tagging this as a bug. Please report it ...
22
votes
5answers
1k views

PDF export on macOS Mojave produces bold fonts

I have updated my OS to macOS 10.14 Mojave. I found whenever I export a plot into a PDF file, the font of the label and ticks are automatically replaced into a bold font. I use Mathematica 11.3. Any ...
34
votes
2answers
2k views

Bug in mathematica analytic integration?

I found Mathematica provides me a wrong answer for a relatively simple analytically solvable integral: ...
13
votes
1answer
466 views

Menu commands on Palettes and other windows without menu bars?

Bug introduced in 10.0.0 and persisting through 10.1.0 or later In the Version 10 interface, at least by default, there is no longer a common menu bar in a separate window, and menus appear to be ...
7
votes
3answers
731 views

Plotting a 3D list causes kernel to crash if x and y axes have vastly different scales

Bug introduced in 7.0.1 or earlier and fixed in 10.0.2 or earlier I have access to two versions of Mathematica, version 7.0.1 on Linux and version 8 on Windows. When I try the following two lines on ...
16
votes
4answers
378 views

Resizing or moving Notebook window causes Manipulate to update its argument

Bug introduced in 10.0 and fixed in 10.3.0 Check this example: Manipulate[Grid[{{RandomReal[10]}, {Plot[Sin[x], {x, 0, 2 Pi}]}}], {a, 1, 3}] As you can see, ...
26
votes
2answers
710 views

Graphics`Mesh`FindIntersections[ ] fails to detect intersections

Graphics`Mesh`FindIntersections[ ] is an undocumented function for, well, detecting intersections very efficiently. Take a look: ...
25
votes
3answers
4k views

Who is to blame: parsing UTF8 encoded JSON HTTPResponse fails

Bug introduced in 11.0 or earlier and persists through 11.3 (confirmed by WRI Support but read summary below) Answers summary I think we need a quick summary here to justify keeping bug. Original ...
22
votes
3answers
845 views

What is a printer's point?

Bug introduced in 10.4 or earlier and persisting through v11.3 (misleading documentation inconsistency) According to the documentation it is a basic unit for size spec. ...
12
votes
3answers
623 views

Why is this parallel evaluation with Dispatch[] so slow?

Can you efficiently parallelize this? The parallel versions are much slower than the sequential version, and I'm not sure why. Does SetSharedVariable allow ...
22
votes
4answers
2k views

Format and TeXForm does not work as expected

Recently, we had a nice question which brought up an issue that I believe is a bug. In the tutorial Defining Output Formats, there is an example at the end which doesn't make sense: This specifies ...
30
votes
3answers
2k views

Save as pdf broken in version 10.0.2?

Fixed in 10.1 It looks like the save as pdf is broken after I update to version 10.0.2. The labels in the plot become a mess. Are there ways to fix it? The Export ...
14
votes
2answers
2k views

Rasterizing a plot make axes ticks invisible [duplicate]

I've evaluated this code: plot = Plot[x, {x, 0, 10}]; g = Rasterize[plot, ImageResolution -> 300]; Everything looks good except the ticks (on the axes); they ...
33
votes
1answer
2k views

What is wrong with triangle PlotMarkers in v.10.0.0?

Bug introduced in 10.0.0 and fixed in 10.0.1 In Mathematica 10.0.0 we have built-in graphical triangle PlotMarkers. Let us look closer on them: ...
7
votes
1answer
837 views

How do I edit the background of Axis labels in my plot?

I'm using the standard report stylesheet in Mathematica and when I output a plot, I've set it up so that I get a white background, however the axis labels still have a gray background. How do I change ...
7
votes
2answers
361 views

Is there something wrong with VertexConnectivity

Note: this is fixed in version 10. As I noticed in the documentation VertexConnectivity is defined as the following The vertex connectivity of a graph $g$ is ...
39
votes
2answers
2k views

Variable naming changes everything

Bug fixed in 10.0.0 I am having a rather unusual problem I do not understand with Mathematica where renaming one of the variables of my function causes the function to stop "working". Here is the ...
24
votes
1answer
601 views

Why does list assignment with a packed array result in unpacked values?

Bug introduced in 5.2 or earlier and fixed in 10.1.0 This is another question on the design choices in Mathematica. I understand that without direct reply from the developers it may not be possible ...
19
votes
3answers
5k views

How to get grid lines at all (log) tick marks in Version 10?

Bug introduced in 10.0.0 and fixed in 10.1.0 Update: It seems that only versions 10.0.0, 10.0.1, and 10.0.2 are affected by this problem. For 10.0.0 there is no general solution known to me due to ...
27
votes
1answer
650 views

In 10.1.0 BenchmarkPlot doesn't work?

Bug introduced in 10.1 This bug was resolved in 10.2.0, but another bug was introduced in 10.3.0 persisting through 10.3.1 and finally resolved in 10.4 In Mathematica 10.1.0 and 10.3.0 ...
21
votes
3answers
839 views

Memory Leak in Frontend - anyone know a workaround?

When using Rasterize on a Graphics expression composed of many differently coloured Graphics objects memory is allocated in the frontend which is then not released or reused when a similar graphic ...
15
votes
1answer
641 views

Grid layout problems: different sizes when rendering on Mac and Windows

From the documentation for ItemSize: {w,h} make all items the specified width and height and In Grid, w is measured in ems, and h in line heights. This ...
11
votes
2answers
799 views

How can I prevent ColorFunction from disabling antialiasing in graphics?

When I use ColorFunction, the appearance of my plots is ruined, changing from this which has the normal smooth lines and antialiased fonts, to this in which the ...
24
votes
1answer
1k views

Colored marks appearing in notebook input text?

Bug introduced in 10, persisting through 11.0.1 or later What is the causing these colored marks to appear in my Mathematica notebook? I'm particularly annoyed with the black ovals that occasionally ...
19
votes
2answers
1k views

Incorrect results for elementary integrals when using Integrate

There is a rather simple integral ($K_0$ is the 0-th order MacDonald function) $$\int_0^\infty e^{-x \cosh\xi}\, d\xi = K_0(x)$$ which mathematica cannot solve. This even though the documentation ...
10
votes
3answers
2k views

How can I completely remove the ListAnimate controls?

I want to use ListAnimate to show an animation but I want to remove the slider and all of the buttons from the top and show the animation panel only. There is an <...
30
votes
2answers
1k views

Strange ::usage behavior in v9

Bug fixed in 9.0.1 Something has gone wrong with usage in Mathematica 9. Would someone tell me how to fix it? I define a function ...