5
$\begingroup$

Just installed Mathematica v10.3 which has the new option to use arXiv, the electronic database. However I get an error message using

arXiv = ServiceConnect["ArXiv"]

articles = arXiv["Search", {"Query" -> "Title" -> "Quantum" | "Cavity", "MaxItems" -> 4}]

(*  The parameter Search  is not available for the service ArXiv . *)

I wonder whether this is specific to my machine.

$\endgroup$
7
$\begingroup$

First I got the same error message. Using the menu bar Edit ► Preferences... and clicking the "Update Local Indices from Wolfram Research Server" button under the Internet Connectivity tab fixed this erroneous behavior.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Worked, once you restart MMA ver 10.3. thanks $\endgroup$ – thils Oct 17 '15 at 5:11
  • 1
    $\begingroup$ @thils I just had to reevaluate arXiv = ServiceConnect["ArXiv"]. $\endgroup$ – Karsten 7. Oct 17 '15 at 5:13
  • $\begingroup$ @thils I simply ran your code, received the message that Mathematica was updating from the Wolfram server, and then I received the desired results. No fuss. Who knows why this works on one machine and not another? $\endgroup$ – bbgodfrey Oct 17 '15 at 19:33
  • $\begingroup$ @bbgodfrey I guess the automatic updates took care of it on your machine. $\endgroup$ – Karsten 7. Oct 17 '15 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.