Bug introduced in 7.0 and fixed in 7.0.1

I run into the following problem, I tried to evaluate a very simple integral:

Assuming[ a > 0  , Integrate[Sin[a*s]/(s - I)^2, {s, -Infinity, Infinity}]]

Mathematica claims the answer is zero, even though you can evaluate it by hand using residues to convince yourself that the answer is:

$I\ a\ \pi\ e^{-a}$

What is weird, is that if you substitute some numerical value instead of a the answer is correct. Also if you switch the pole to be +I Mathematica gives an incorrect answer:

$-2\ I\ a\ \pi\cosh(a)$

instead of simply minus the previous result. Anyone had a problem like this?

  • 1
    $\begingroup$ I get E^-a Pi. Mma v $\endgroup$ – Dr. belisarius Aug 21 '12 at 16:52
  • 1
    $\begingroup$ what version of Mathematica are you using? I get the same result as others above on 8.04 (OSX) $\endgroup$ – rm -rf Aug 21 '12 at 18:22
  • 4
    $\begingroup$ Emksajot, welcome to Mathematica.SE! Please consider registering your account so that any upvotes you get on this question are added to those you might get on future questions and answers. That way, over time you will be able to do more on the site (post graphics, edit things, etc). Another tip: after posting a question stay around for a little while, to answer questions raised by commenters. This will streamline the Q&A process considerably. $\endgroup$ – Sjoerd C. de Vries Aug 21 '12 at 19:53
  • 1
    $\begingroup$ Well ... so it seems there was bug in v7.0.0 corrected in v7.0.1 onwards. There is not much else to do. $\endgroup$ – Dr. belisarius Aug 22 '12 at 11:32
  • 1
    $\begingroup$ @Verde then maybe we mark it as a bug and tag it v.7. $\endgroup$ – rcollyer Aug 22 '12 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.