18
$\begingroup$

Bug introduced in 10.2 and fixed in 11.1

I have noticed that OpenCL stopped working on Intel HD Graphics 4600 (Windows 8.1 x64, Windows 10 x64, latest Intel graphic drivers). Can anyone confirm this problem? I hope to attract the attention of QA Engineers. I have filled bug report [CASE:3420032]. After long waiting I have received the strange answer. But on my comments I have not received an answer for a month. In Mathematica 10.0 OpenCL worked on the same hardware.

In[1]:= Needs["OpenCLLink`"]

In[2]:= OpenCLQ[]

Out[2]= False

In[3]:= OpenCLInformation[]

OpenCLInformation::invdevnm: OpenCL is not supported on device Intel(R) HD Graphics 4600. Refer to OpenCLLink System Requirements for system requirements. >>

Out[3]= OpenCLInformation[]

Maybe someone has solution for this problem similarly like this?

UPDATE

The problem was confirmed on another computer with a discrete card NVidia GTS450 (OS Windows 7). I changed the title and tagged 'bugs'.

$\endgroup$
3
$\begingroup$

I have a Dell 17R SE with nVIDIA GeForce GT650M with 3D capabilities and Mathematica 10.3 on Windows 10 64bit.

The automatically downloaded paclet was version 8. So I downloaded from the Wolfram website CUDAResources-Win64-10.0.0.1.paclet and installed manually.

With this paclet OpenCL does not work, while CUDA is OK.

I reported these issues to support@wolfram.com [CASE:3449092] 10 days ago and did not even get an answer :-(

UPDATE

Today I got an answer on my email to support@wolfram.com saying there was no issue on the machine of the support engineer.

So I again let Mathematica install the CUDA paclet. The download was extremely slow. But in the end version 10.2.0.3 was installed. And now both CUDA and OpenCL work perfectly. So the Wolfram engineers solved both of my issues!

$\endgroup$
  • $\begingroup$ Does OpenCL work on the Intel 4600 or only on the Nvidia 650? $\endgroup$ – Oleksandr R. Nov 9 '15 at 20:18
  • $\begingroup$ @OleksandrR. In Mathematica 10.3 OpenCL does not work on Intel HD 4600. $\endgroup$ – Alexey Golyshev Nov 19 '15 at 8:41
  • $\begingroup$ @AlexeyGolyshev is that an official determination by WRI? And, if so, what are the reasons for it? Will it work if you install a different/newer graphics driver and/or OpenCL SDK, for example? I mean, "it doesn't work for me" is not quite the same as "it will not work at all". $\endgroup$ – Oleksandr R. Nov 19 '15 at 13:28
  • $\begingroup$ @OleksandrR. "It doesn't work for me". I checked in trial of 10.3. I use Windows 10 with latest graphics driver. Original [CASE] was created in the chat with support in the end of August. In the mid of September I received strange message by email: "Intel HD Graphics 4600 is an officially supported hardware so we do not test the OpenCL functionalities on it... Did you try evaluating Needs["OpenCLLink`"] before evaluating OpenCLInformation[]?" $\endgroup$ – Alexey Golyshev Nov 19 '15 at 18:28
  • $\begingroup$ @OleksandrR. I sent the comment that of course I have evaluated Needs["OpenCLLink`"]. It should be noted that in chat I have sent only part of code: OpenCLInformation[] and error message. Since September there is no answer. $\endgroup$ – Alexey Golyshev Nov 19 '15 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.