7
$\begingroup$

I have been trying to get CUDA to work in Mathematica for kernel development.

I downloaded and installed Visual Studio 2013 Community and the latest NVIDIA developers toolkit 7.5 (in that order).

Using that toolchain I can develop self contained CUDA programs.

Sadly, I appear to have gone backwards regarding Mathematica, ie I am pretty sure that prior to installing that toolchain, that the predefined Mathematica CUDA functions, e.g. CUDADot were working fine.

Now, however:
CUDAQ[] returns False and CUDADriverVersion[] returns "Mod[100 Revision Number, 1000]" which doesn't look right.

I have tried CUDAResourcesInstall[Update -> True]

I also tried doing a system restore to the point before installing NVIDIA drivers, but I had the same problem.

$CUDALinkLibraryPath

evaluates to:

"C:\\Program Files\\Wolfram \
Research\\Mathematica\\10.2\\SystemFiles\\Links\\CUDALink\\\
LibraryResources\\Windows-x86-64"

I am a bit suspicious as there is nothing installed in this directory (I don't have a LibraryResources subdirectory).

I am stuck at this point.

Any advice gratefully received

$\endgroup$
  • $\begingroup$ What processor do you have? On my older laptop with a 435M I got it to work, but on my newer one with a 980M I never had such luck. Many configuration differences though, so difficult to pinpoint the precise cause. $\endgroup$ – Sjoerd C. de Vries Oct 11 '15 at 11:45
  • $\begingroup$ It's a K4200 card, core is GK104GL apparently. It's a bit frustrating as I'm pretty sure that the built in funcs were working before. Well at least now, I can compile my own CUDA functions using NVCC (providing I remember to run vcvarsall first if I'm using DOS prompt). $\endgroup$ – Julian Francis Oct 11 '15 at 11:59
  • $\begingroup$ I think a bugs tag for this question is justified by the fact that CUDAResourcesInstall[Update -> True] installs the wrong paclet. $\endgroup$ – Karsten 7. Oct 11 '15 at 12:45
9
$\begingroup$

I recently encountered a similar problem (CUDAQ[] returning False, CUDADriverVersion[] returning that strange "Mod[100 Revision Number, 1000]"). Here are the steps that finally got the CUDALink back working properly:

  1. Uninstalling by executing

    CUDAResourcesUninstall[]
    
  2. Downloading the proper paclet from http://www.wolfram.com/CUDA/CUDAResources.html

  3. Reinstallation by executing (using the file path of the downloaded paclet)

    CUDAResourcesInstall["D:\\Downloads\\CUDAResources-Win64-10.0.0.1.paclet"]
    

Do not use CUDAResourcesInstall[] or CUDAResourcesInstall[Update -> True] for the reinstallation, as these installed an older version ({Paclet[CUDAResources, 8.0.4.2, <>]}) which caused the problems.

$\endgroup$
  • $\begingroup$ That's great. Thanks Karsten. My CUDA is back! $\endgroup$ – Julian Francis Oct 11 '15 at 13:06
4
$\begingroup$

I have a Dell 17R SE with nVIDIA GeForce GT650M with 3D capabilities and Mathematica 10.3 on Windows 10 64bit.

Today I got an answer on my email to support@wolfram.com saying there was no issue on the machine of the support engineer.

So I again let Mathematica install the CUDA paclet. The download was extremely slow. But in the end version 10.2.0.3 was installed. And now both CUDA and OpenCL work perfectly. So the Wolfram engineers solved both of my issues! See also OpenCL stopped working‏ in Mathematica 10.2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.