2
$\begingroup$

I'm trying to copy Mathematica figures into word, but when I do, I get tons of extra white-space for some reason. Either standard ctrl-c - ctrl-p or "copy graphic" does this.

I understand that I could export the figure as a graphic, open the png file, and copy it from there into my word document, but I feel like there must be a better way to do this. It's possible this is not a Mathematica issue, but I've only noticed this type of thing when copying pictures from Mathematica. Can anyone help?

extra whitespace from *Mathematica*

This problem occurs for me given even the most basic plot (e.g. Plot[x,{x,-1,1}]). I'm using Mathematica 10.2 Student Edition and the Word 2016 Preview. The Word 2016 preview might seem suspect, but I'm pretty sure I was having the exact same problem before with word 2013.

Partial Solution: I have no idea what the problem is with my system, but using Copy as Bitmap fixed this issue for me.

It still happens with Copy as Metafile.

$\endgroup$
  • 1
    $\begingroup$ Related: (54708), (38715). $\endgroup$ – Alexey Popkov Sep 27 '15 at 8:00
  • 1
    $\begingroup$ I can not reproduce the extra white spaces using a simple Plot. You might add some code that creates a simplified Plot that can reproduce the behavior you observed. $\endgroup$ – Karsten 7. Sep 27 '15 at 8:04
  • 2
    $\begingroup$ I can NOT reproduce your problem. Office 2007, Windows 7SP1 64bit. Tried Copy as Bitmap and Copy as Metafile. You should give more information about yous system and formatted code. $\endgroup$ – rhermans Sep 27 '15 at 8:10
  • 1
    $\begingroup$ Edit > Copy As...> Last two options, look here: i.stack.imgur.com/F2CHO.png $\endgroup$ – rhermans Sep 27 '15 at 8:18
  • 1
    $\begingroup$ I cannot reproduce the problem with Mathematica 10.2 and Word 2003 on Win7 x64. $\endgroup$ – Alexey Popkov Sep 27 '15 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.