3
$\begingroup$

There is an odd white mesh that appears on top of any contour plot I make.

ContourPlot[x + 2 y, {x, 80, 300}, {y, 50, 100}]

enter image description here

Any ideas on how I get rid of this? I've tried a new notebook with just that command but it does not go away.

Just adding that this is also happening in the ContourPlot help page so I think some global variable has been set that is doing this. Restarting Mma has not helped.

Version 10.2 on Win 8.1 64-bit.

Added output of Options

Options[ContourPlot]
{AlignmentPoint -> Center, AspectRatio -> 1, Axes -> False, 
 AxesLabel -> None, AxesOrigin -> Automatic, AxesStyle -> {}, 
 Background -> None, BaselinePosition -> Automatic, BaseStyle -> {}, 
 BoundaryStyle -> None, BoxRatios -> Automatic, ClippingStyle -> None,
  ColorFunction -> Automatic, ColorFunctionScaling -> True, 
 ColorOutput -> Automatic, ContentSelectable -> Automatic, 
 ContourLabels -> Automatic, ContourLines -> True, 
 Contours -> Automatic, ContourShading -> Automatic, 
 ContourStyle -> Automatic, CoordinatesToolOptions -> Automatic, 
 DisplayFunction :> $DisplayFunction, Epilog -> {}, 
 Evaluated -> Automatic, EvaluationMonitor -> None, 
 Exclusions -> Automatic, ExclusionsStyle -> None, 
 FormatType :> TraditionalForm, Frame -> True, FrameLabel -> None, 
 FrameStyle -> {}, FrameTicks -> Automatic, FrameTicksStyle -> {}, 
 GridLines -> None, GridLinesStyle -> {}, ImageMargins -> 0., 
 ImagePadding -> All, ImageSize -> Automatic, 
 ImageSizeRaw -> Automatic, LabelStyle -> {}, LightingAngle -> None, 
 MaxRecursion -> Automatic, Mesh -> None, MeshFunctions -> {}, 
 MeshStyle -> Automatic, Method -> Automatic, 
 PerformanceGoal :> $PerformanceGoal, PlotLabel -> None, 
 PlotLegends -> None, PlotPoints -> Automatic, 
 PlotRange -> {Full, Full, Automatic}, PlotRangeClipping -> True, 
 PlotRangePadding -> Automatic, PlotRegion -> Automatic, 
 PlotTheme :> $PlotTheme, PreserveImageOptions -> Automatic, 
 Prolog -> {}, RegionFunction -> (True &), RotateLabel -> True, 
 TargetUnits -> Automatic, Ticks -> Automatic, TicksStyle -> {}, 
 WorkingPrecision -> MachinePrecision}
$\endgroup$
  • $\begingroup$ Looks like a "TransparentPolygonMesh" mesh problem, but I cannot reproduce it. Possible duplicate(?): mathematica.stackexchange.com/questions/1400/… $\endgroup$ – Michael E2 Sep 6 '15 at 14:09
  • 1
    $\begingroup$ Cannot reproduce with version 10.2 on Windows 7 x64. $\endgroup$ – Alexey Popkov Sep 6 '15 at 15:41
  • 2
    $\begingroup$ There is no white mesh with the above Option[ContourPlot]; Windows 10 and Mma 10.2 $\endgroup$ – user31001 Sep 6 '15 at 17:21
  • 1
    $\begingroup$ I'm voting to close this question as off-topic because the problem could not be reproduced. $\endgroup$ – MarcoB Sep 7 '15 at 4:59
  • 2
    $\begingroup$ @MarcoB Please give a larger benefit of the doubt on reproducibility. In this case for example I can easily reproduce the problem. Not everyone has the same platform and system configuration and many localized idiosyncrasies appear as a result. $\endgroup$ – Mr.Wizard Sep 7 '15 at 7:08
3
$\begingroup$

Closely related:

I can easily reproduce your problem in 10.1 under Windows 7 merely by setting:

SetOptions[$FrontEndSession, Antialiasing -> True]

Example of output then produced:

enter image description here

This is a case of anti-aliasing gone wrong, and it is normally handled correctly by the default setting of Automatic:

SetOptions[$FrontEndSession, Antialiasing -> Automatic]

If this fixes your problem change [$FrontEndSession](http://reference.wolfram.com/language/ref/$FrontEndSession.html) to `$FrontEnd` to make the setting persist.

If setting Automatic does not fix the problem the cause it very likely the same anyway but from a different source. Do you have a video card set to force AA in all applications? Try changing that to "application preference" or similar.

$\endgroup$
  • $\begingroup$ So it seems my question is a duplicate as I didn't know exactly what to search for. $\endgroup$ – Edmund Sep 7 '15 at 10:42
  • $\begingroup$ @Edmund That's OK, and thanks for searching before posting. Your question will probably help make searching easier for others with the same issue. Did SetOptions[$FrontEnd, Antialiasing -> Automatic] fix the problem? $\endgroup$ – Mr.Wizard Sep 7 '15 at 19:38
  • $\begingroup$ Yes, I had upgrading both my graphics drivers. I think it was from the Intel driver as I have upgraded the Nvidia ones many times before without issue. Also, the default is the Intel on board GPU so Mma was running on that. $\endgroup$ – Edmund Sep 7 '15 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.