80
$\begingroup$

Bug caused by paclet update and fixed by paclet update.


I updated to Windows 10 and have been running Mathematica fine on it for over a month. For some reason, it has just stopped working. I don't remember any Windows updates occurring which would have caused this, and I didn't change any settings in Mathematica for weeks.

When I end task on the kernel, it gives the message 'Unable to launch kernel system'. Has anyone else has experienced this in Windows 10?

$\endgroup$
2
  • $\begingroup$ This happened to me on Windows 7. $\endgroup$ Sep 5, 2015 at 23:11
  • 1
    $\begingroup$ It just happened to me with Mathematica 10.0.0 on Windows 8.1 The below fix works fine in this case too. $\endgroup$
    – mattiav27
    Sep 6, 2015 at 8:36

2 Answers 2

100
$\begingroup$

Yes, there was a recently pushed incorrect paclet update that will cause this startup hang. All platforms can be affected, not just Windows.

For a workaround, start a standalone kernel (WolframKernel.exe on Windows, WolframKernel in a terminal on Linux; on Mac you will need the full path to the kernel binary, typically a location like /Applications/Mathematica.app/Contents/MacOS/WolframKernel) and evaluate

PacletSiteUpdate /@ PacletSites[]

PacletUpdate["CloudObject"]

which should allow a normal startup afterwards.

It is also possible to

  • disable your computer's network connection
  • start Mathematica
  • turn on the network connection
  • evaluate

    PacletSiteUpdate /@ PacletSites[]

    PacletUpdate["CloudObject"]

after which things should work again, even if the network connection is left enabled.

Update

As of this edit, the broken paclet is no longer on the server. For those still experiencing the startup hang, the steps above still work, but the easiest fix would be to either delete the entire Paclets folder or just the pacletSiteData_10.pmd2 file, which is located in the user base directory, typically under

  • C:\Users\<username>\AppData\Roaming\Mathematica\Paclets\Configuration on Windows
  • ~/.Mathematica/Paclets/Configuration on Linux
  • ~/Library/Mathematica/Paclets/Configuration on Mac OS X
$\endgroup$
14
  • 25
    $\begingroup$ Just FYI - It would be courteous to send an email informing users when a push is done, especially with fix information ASAP after discovery of a problem that breaks the system! This is the second time this year of paclet updates breaking my system. $\endgroup$ Sep 4, 2015 at 20:29
  • 2
    $\begingroup$ For the Mac, open terminal and type: /Applications/Mathematica.app/Contents/MacOS/WolframKernel $\endgroup$ Sep 6, 2015 at 9:36
  • 1
    $\begingroup$ Just testing this now, it fails for me with: PacletInstall::dwnld: An error occurred downloading paclet CloudObject-10.3.760 from site pacletserver.wolfram.com: Network error. Failure when receiving data from the peer $\endgroup$ Sep 6, 2015 at 9:43
  • 1
    $\begingroup$ @JGregoryMoxness, illian -- My Mac OS updates are handled by requiring the me to click a button (or two) to start the update. MS Office, Google Picasa, Flash, etc. also are only updated when I click OK. Is it really not feasible for my local kernel to query me before proceeding with an update? $\endgroup$
    – Michael E2
    Sep 6, 2015 at 14:15
  • 4
    $\begingroup$ @Italianice They should email non-premier service users too $\endgroup$
    – Coolwater
    Sep 10, 2015 at 13:05
19
$\begingroup$

I'm adding an alternate solution for Mac, as the suggested answer did not work for me. It might be due to me force quitting it prior to looking for a solution.

This method is a bit of a scorched earth process though.

In Finder go to ~/Library/Mathematica. Once there delete the Paclets folder.

Next start up Mathematica again. Create a blank worksheet. Then evaluate PacletUpdate["CloudObject"].

Wait for the Out response before quitting Mathematica.

$\endgroup$
4
  • 7
    $\begingroup$ This is a good solution, I would recommend deleting just the ~/Library/Mathematica/Paclets folder, so it won't be necessary to reactivate. $\endgroup$
    – ilian
    Sep 6, 2015 at 14:12
  • $\begingroup$ cheers. I've updated the answer. $\endgroup$ Sep 6, 2015 at 18:26
  • $\begingroup$ Simon - I had the same problem, your solution worked fine! $\endgroup$
    – Paul R.
    Sep 7, 2015 at 16:17
  • $\begingroup$ Worked for me on Mac OS 10.8.5, with Mathematica 10.0.1.0 $\endgroup$
    – jibe
    Sep 10, 2015 at 9:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.