I have a file that I can't reopen because MMa was "Not Responding" and I had to shut it down.

I found links online to this: http://support.wolfram.com/kb/12423

I executed those two instructions in a new notebook, but no "NotebookRestore dialogue" appeared, whatever that is.

What am I missing here?

  • $\begingroup$ mathematica.stackexchange.com/search?q=[notebooks]+corrupted $\endgroup$ Sep 2, 2015 at 7:27
  • $\begingroup$ @belisarius Not one useful answer in any of that. I tried Daniel W's CleanNotebookOpen[] program, but the Import[] failed because of the corruption. $\endgroup$ Sep 2, 2015 at 8:02
  • 1
    $\begingroup$ I'd use a simple ASCII editor to open the file and see whether it would be possible to salvage complete cells from it and perhaps try to close unclosed (because of missing closing brackets) function code. $\endgroup$ Sep 2, 2015 at 8:43
  • 1
    $\begingroup$ Can you try the following, but with a copy of your corrupted file: Needs["AuthorTools`"]; NotebookRestore[] $\endgroup$
    – user9660
    Sep 2, 2015 at 9:11
  • 1
    $\begingroup$ @Jerry Guern, I like your your choice of words. $\endgroup$
    – user9660
    Sep 2, 2015 at 13:08

1 Answer 1


You can try the following, but with a copy of your corrupted file:


which opens a new window.

N.B.: works on " for Mac OS X x86 (64-bit) (December 4, 2014)"

  • $\begingroup$ THAT WORKED! Thank you! $\endgroup$ Sep 2, 2015 at 14:22
  • 1
    $\begingroup$ If you type Import<leftBracket><quote><space> a Browse icon will pop up, then if you click on your corrupt file, MMa will fill in the complete path to the file, which you can then cut-paste into the brackets in NotebookRestore[]. $\endgroup$ Sep 2, 2015 at 14:28
  • 1
    $\begingroup$ @JerryGuern there's also the Insert>File path menu $\endgroup$ Sep 3, 2015 at 17:02
  • $\begingroup$ @SjoerdC.deVries I had a feeling that if I posted my clunky method someone would post something better. Thank you! $\endgroup$ Sep 3, 2015 at 17:17
  • 2
    $\begingroup$ link to this on the support site support.wolfram.com/kb/12423. One does wonder why the front end doesn't just offer to do this automatically. $\endgroup$
    – george2079
    Aug 26, 2016 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.