1
$\begingroup$

I cannot get the label to appear on this vertical line! (Mma 9.0.1 OS 10.8)

ParametricPlot[{.5, t}, {t, 0, .5}, PlotStyle -> Blue, PlotLabel -> "z"]
| improve this question | | | | |
$\endgroup$
  • $\begingroup$ Works fine on MMA 10.2, MBP OS 10.10.5. What version are you using? $\endgroup$ – Bob Hanlon Aug 26 '15 at 13:51
  • $\begingroup$ Version 9.0.1.0 OS 10.8.5 $\endgroup$ – guest Aug 26 '15 at 13:54
  • $\begingroup$ Also works fine on MMA 9.0.1, MBP OS 10.10.5. Apparently the problem is with OS 10.8.5 $\endgroup$ – Bob Hanlon Aug 26 '15 at 14:00
  • $\begingroup$ Welcome to Mathematica.SE! I hope you will become a regular contributor. To get started, 1) take the introductory Tour now, 2) when you see good questions and answers, vote them up by clicking the gray triangles, because the credibility of the system is based on the reputation gained by users sharing their knowledge, 3) remember to accept the answer, if any, that solves your problem, by clicking the checkmark sign, and 4) give help too, by answering questions in your areas of expertise. $\endgroup$ – bbgodfrey Aug 26 '15 at 14:15
  • 2
    $\begingroup$ Can you perhaps include a screen shot of what you see (or don't see) and mark where you expect to see a label? $\endgroup$ – Arnoud Buzing Aug 26 '15 at 15:00
1
$\begingroup$

The question is not clear, so far, but I assume you mean the PlotLegends and not PlotLabel.

Mathematica 10

ParametricPlot[
 {.5, t}
 , {t, 0, .5}
 , PlotStyle -> Blue
 , PlotLabel -> "here the plot Label"
 , PlotLegends -> {"here your legend"}
 , FrameLabel -> {"botoom", "left", "top", "right"}
 , PlotTheme -> "Detailed"
 ]

Mathematica graphics

Mathematica 9

ParametricPlot[
 {.5, t}
 , {t, 0, .5}
 , PlotStyle -> Blue
 , Frame -> True
 , PlotLabel -> "here the plot Label"
 , PlotLegends -> {"here your legend"}
 , FrameLabel -> {"botoom", "left", "top", "right"}
 ]

enter image description here

| improve this answer | | | | |
$\endgroup$
0
$\begingroup$

(Stumbled upon this question while looking for something similar. I'm not sure if a more elegant way to add labels to ParametricPlot exists, but this is what I've decided to go with...)

Assuming you did mean "PlotLabel" and not "PlotLegends", you can add the label manually.

Show[{
  ParametricPlot[{.5, t}, {t, 0, .5}, PlotStyle -> Blue, 
   PlotRange -> {Automatic, {0, 0.6}}], 
  Graphics[Text["z", {1/2, 0.55}]]
  }]

That would give the following plot:

enter image description here

| improve this answer | | | | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.