4
$\begingroup$

I altered the notebook stylesheet ArticleJournal to my needs and I'm using it as a private stylesheet. However, every time a new line is encountered; it assumes as text by default since its a journal article and it makes sense. How can I change it to "input".

$\endgroup$
3
$\begingroup$

Use the Option Inspector to change the DefaultNewCellStyle to Input in your stylesheet notebook.

inspector

$\endgroup$
9
  • 1
    $\begingroup$ This worked for current open notebook, I tried to Format-> Edit Stylesheet and change the cell options inside it; How can I apply it to the stylesheet so that it's scope is global when ever I use this stylesheet. $\endgroup$ Aug 21 '15 at 13:51
  • $\begingroup$ Open the stylesheet as a notebook, make this change in that notebook. and save it as a stylesheet. Any new notebook created in changed style should have the new behavior. $\endgroup$
    – m_goldberg
    Aug 21 '15 at 20:55
  • $\begingroup$ It does not work. New cells only in the style sheet are input cells, which is useless. $\endgroup$ Mar 17 '20 at 11:22
  • $\begingroup$ @PierreALBARÈDE. After you made the change in the style sheet notebook did you save it so that it replaced the previous version? Did you quit Mathematica and start a new session with a fresh notebook and apply the saved style sheet to it? $\endgroup$
    – m_goldberg
    Mar 17 '20 at 18:13
  • $\begingroup$ I have restarted Mathematica, installed the style sheet and it works very well with new files, except for this particular option DefaultNewCellStyle. I am sure the option has been set in the style sheet since it is effective therein. Only inheritance of this option is broken. $\endgroup$ Mar 18 '20 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.