3
$\begingroup$

I have Mathematica 10.1 running on a Windows 7 laptop (i7 processor, 64-bit system with 4 GB Ram). The issue is that when I type in commands the letters build up very slowly on the screen. E.g. when I write Interpolation, I see Interpo on the screen when I have finished writing it. The rests builds up slowly after hat. Apart from that I have no issue with the speed of the evaluations.

Does anyone have an idea how to speed it up?

$\endgroup$
  • 1
    $\begingroup$ I had this problem once and I linked it to an anti-virus program I had installed. The Front End apparently writes to disk with every keystroke and this particular AV did not handle that well. (I cannot remember which one it was now.) Try turning off anything that is tracking disk writes and see if that solves your problem. $\endgroup$ – Mr.Wizard Aug 20 '15 at 9:24
  • $\begingroup$ I checked with the IT department here and we did not pin point it to the virus scan as Mathematica was creating 10% processor load and the virus scan almost nothing. Anyhow, I have a new version of virus scan now as the old was outdated and now it is fast :). I can not pin point it as the root cause but it was the only indication. $\endgroup$ – Eisbär Sep 2 '15 at 9:11
  • $\begingroup$ So your problem is solved? That's great! The issue with the AV appears not to be CPU usage, but rather (I believe) a small delay introduced which is reflected (or magnified?) by the Front End because of its unusual behavior. $\endgroup$ – Mr.Wizard Sep 2 '15 at 17:30
  • $\begingroup$ Yes, it is solved. Thank you for the advice! $\endgroup$ – Eisbär Sep 2 '15 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.