2
$\begingroup$

I recently upgraded to Mathematica 10.2.0.0 for Linux (32-bit). In the past I have used the ErrorBarLogPlots package to put error bars on logarithmic plots of lists. When I make a simple ErrorListLogLogPlot, everything seems reasonable:

ErrorListLogLogPlot[Table[{{kk, 2*kk}, ErrorBar[kk]}, {kk, 1, 5}], PlotRange -> {{0.5, 6}, {0.5, 20}}, Axes -> False, Frame -> True]

produces:

enter image description here

When PlotMarkers are added,

ErrorListLogLogPlot[Table[{{kk, 2*kk}, ErrorBar[kk]}, {kk, 1, 5}], PlotRange -> {{0.5, 6}, {0.5, 20}}, Axes -> False, Frame -> True, PlotMarkers -> Automatic]

the error bars disappear:

enter image description here

When Joined is True, the error bars return,

ErrorListLogLogPlot[Table[{{kk, 2*kk}, ErrorBar[kk]}, {kk, 1, 5}], PlotRange -> {{0.5, 6}, {0.5, 20}}, Axes -> False, Frame -> True, PlotMarkers -> Automatic, Joined -> True]

What am I doing wrong?

$\endgroup$
2
  • 1
    $\begingroup$ Reference for the package is in this Q&A. $\endgroup$
    – Jens
    Commented Aug 14, 2015 at 0:20
  • 1
    $\begingroup$ It seems to be the same problem that in PlotMarkers problem in ErrorListPlot, Mathematica 10 but this has been fixed in 10.1 as it belongs to the standard packages, contrary to the ErrorBarLogPlots package ... Look at the comments in that post, there seem to be a workaround using Method -> {"OptimizePlotMarkers" -> False} which "has to go before the PlotMarkers option for this to work" according to the user evanb. Maybe it will work in your case. $\endgroup$
    – SquareOne
    Commented Aug 15, 2015 at 16:31

1 Answer 1

1
$\begingroup$

Addition of Method -> {"OptimizePlotMarkers" -> False} solves the problem:

Needs["ErrorBarLogPlots`"]

ErrorListLogLogPlot[Table[{{kk + i/3, 2 kk}, ErrorBar[kk]}, {i, 1, 3}, {kk, 1, 5}], 
 PlotRange -> {{1, 10}, {1, 20}}, Axes -> False, Frame -> True, PlotMarkers -> Automatic, 
 Method -> {"OptimizePlotMarkers" -> False}]

plot

$\endgroup$
2
  • $\begingroup$ I am running Mathematica 10.4.0. When I run all your example code I get the following error: Get::noopen: Cannot open ErrorBarLogPlots. >> Needs::nocont: Context ErrorBarLogPlots was not created when Needs was evaluated. >> What am I doing wrong? $\endgroup$
    – mrz
    Commented Apr 2, 2016 at 5:26
  • $\begingroup$ You should download the package here and install it. $\endgroup$ Commented Apr 2, 2016 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.