12
$\begingroup$

Update 2015 September 4: An incorrect paclet update was pushed recently that caused Mathematica to not hang on startup with "Initializing kernels". The problem and solution are described here: Mathematica 10.0.x freezes in Initializing kernels.


In version 10.1.0 under Windows 7 x64 I have a repeating problem. Every time I start the Mathematica Front End the Welcome to Wolfram Mathematica screen appears, then freezes and eventually is marked (Not Responding) by Windows.

(It does not matter whether Welcome screen or New document is selected as the show-on-startup action; the Front End freezes in either case immediately after that object is displayed.)

How can I fix this?

$\endgroup$
  • 2
    $\begingroup$ I confirm exactly the same problem in Mathematica 10.0.2 / Win7. The workaround with deleted pacletSiteData_10.pmd2 and disabling data updates did work. Thanks! P. $\endgroup$ – user32791 Sep 3 '15 at 9:22
  • $\begingroup$ There was a very recent broken CloudObject paclet push that will cause 10.0.x installations to hang at "Initializing kernels...". I do not believe it is the same problem, because it is readily reproducible and based on the timing, though the workaround given by Mr.Wizard will obviously apply. $\endgroup$ – ilian Sep 3 '15 at 23:10
  • $\begingroup$ This seems to be getting many hits due to the bugged paclet update. Since you were not around, I took the liberty to edit in a link at the top. Please revert it if you think that's better, otherwise we can revert in a few days when the problem is gone. $\endgroup$ – Szabolcs Sep 4 '15 at 15:29
  • $\begingroup$ @PetrS You saved my day! I just encounter starting problem, I have re-start windows several times, re-install the mathematica, all failed! Just delete pacletSiteData_10.pmd2 works perfectly $\endgroup$ – matheorem Nov 23 '15 at 6:58
  • $\begingroup$ @matheorem Glad I could help. :-) $\endgroup$ – Mr.Wizard Nov 24 '15 at 13:45
15
$\begingroup$

The only solution I have found is to delete the contents of the directory given by:

FileNameJoin[{$UserBaseDirectory, "Paclets"}]

More specifically it appears to be sufficient to delete a single file:

FileNameJoin[{$UserBaseDirectory, "Paclets", "Configuration", "pacletSiteData_10.pmd2"}]

To prevent Mathematica freezing on the next start-up I need to turn off Automatically check for data updates in the Internet Connectivity tab of the Preferences menu.

I presume that some automatic data update is incompatible with my version; hopefully it will be identified and fixed.

I am posting this for anyone else who might have this problem and is in need of a quick solution.

$\endgroup$
  • $\begingroup$ This is very alarming! We did just recently push a 10.1.0-exclusive Dataset paclet, which will be auto-installed (it contains a relatively minor fix). However, this should certainly not cause a freeze on startup! $\endgroup$ – Stefan R Aug 6 '15 at 19:22
  • $\begingroup$ @StefanR I take it you will be looking into this, and thank you in advance. :-) $\endgroup$ – Mr.Wizard Aug 6 '15 at 19:23
  • $\begingroup$ Do you by any chance know the contents of the Paclets directory? Is there any specific paclet that's causing problems? $\endgroup$ – Stefan R Aug 6 '15 at 19:30
  • $\begingroup$ @StefanR Sorry, I do not. I deleted everything in there. I could re-enable "Automatically check for data updates" and let the Front End freeze, and watch to see if anything appears in /Paclets if you think that would be useful. $\endgroup$ – Mr.Wizard Aug 6 '15 at 19:38
  • $\begingroup$ I think that would be very helpful, thanks! $\endgroup$ – Stefan R Aug 6 '15 at 19:41
1
$\begingroup$

The problem has been solved with firewall of Windows. All executable files Mathematica need to add an exception of firewall

$\endgroup$
  • $\begingroup$ I believe I have my firewall configured correctly and I still have this problem unless I leave Automatically check for data updates disabled. Would you include the specific exception you are using for the Windows Firewall? $\endgroup$ – Mr.Wizard Sep 3 '15 at 21:27
  • $\begingroup$ First you need to delete this !damn! file pacletSiteData_10.pmd2. Then, before runnign Mathematica, add all the executable files in the Windows Firewall exceptions. I have not tried which exactly file donwloading again pacletSiteData_10.pmd2, so added all files: math.exe , Mathematica.exe, MathKernel.exe and so on. Hope this help you) $\endgroup$ – mez0n Sep 4 '15 at 4:24
  • $\begingroup$ Ah, I see, you're blocking Mathematica rather than allowing it. That apparently works like disabling Automatically check for data updates which is my solution. I believe ilian was suggesting that not properly allowing connectivity might be the source of the problem, which is why I was initially confused by this answer. Thanks for reporting this. $\endgroup$ – Mr.Wizard Sep 4 '15 at 4:36
  • $\begingroup$ Hm, disabling all updates in Mathematica works too, but file pacletSiteData_10.pmd2 downloading again.It's confusing.... $\endgroup$ – mez0n Sep 4 '15 at 4:55
0
$\begingroup$

In case it helps someone: I just had this freezing problem on both MMA 11.0.1 and 10.3 using Ubuntu 16.04.

The problem was actually not caused by MMA but by wrong permissions on my home folder and, possibly, ~/.dmrc. Once this corrected and after a reboot, everything was back to normal.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.