This question already has an answer here:

It doesnt even oscillate that much

Plot[Exp[-Pi x^2 + I ( 60 1/(x^2 + .6) + 0.2)] // Re, {x, -2, 2}, 
 PlotRange -> Full, MaxRecursion -> 15]

enter image description here

What is wrong? How to fix?


marked as duplicate by Oleksandr R., MarcoB, Simon Woods, george2079, m_goldberg Jul 30 '15 at 20:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ Try adding PlotPoints -> 100 or the like $\endgroup$ – Dr. belisarius Jul 30 '15 at 18:25
  • $\begingroup$ Yup, did the trick. $\endgroup$ – grdgfgr Jul 30 '15 at 18:36
  • 1
    $\begingroup$ I voted your question as a duplicate of the one linked, because it is the same issue with the same solution, regardless of the function in that case being ParametricPlot while the one here is just Plot. Please see also the questions referenced in the proposed duplicate question for additional details. To put it briefly: the correct thing to do is to use the (unfortunately undocumented) option Method -> {Refinement -> {ControlValue -> (*angle in radians*) }}, with a suitably small angle. Since this is the root of the problem, adding sampling points will not necessarily help. $\endgroup$ – Oleksandr R. Jul 30 '15 at 18:39

Browse other questions tagged or ask your own question.