13
$\begingroup$

I have Linux on a HiDPI laptop, and after first installing Mathematica, the default font size is far too small:

Default settings on Mathematica

After searching for a few solutions, this can be fixed by either changing the magnification to 200% (in Notebook Options -> Display Options -> Magnification), or alternatively doubling the screen resolution in Formatting Options -> Font Options -> FontProperties -> ScreenResolution. (They seem, as far as I can tell, equivalent?)

Anyway, whichever method I end up choosing, it ends up magnifying another issue: the horizontal width of elements is small than the display width of these elements:

incorrect horizontal width

As you can see, some elements start running into each other, or alternatively get cropped by other elements. This issue is already present (though to a lesser extent) in the non-magnified display (you can see that 't' of Dataset is cropped).

In this particular picture, it is merely an inconvenience, but I am regularly finding a few instances where it is much more severely impacting the legibility of the output. For example:

really bad horizontal spacing

Has anyone else experienced this issue? And how can I fix it, or at least improve legibility?

$\endgroup$
6
  • $\begingroup$ Have you reported this issue to [email protected]? If not, you should do it. $\endgroup$
    – halirutan
    Jul 30, 2015 at 1:05
  • 2
    $\begingroup$ I did not originally, but I have contacted them now. They may answer here, or if they answer by email, I shall post their response here. $\endgroup$
    – JP-Ellis
    Jul 30, 2015 at 1:57
  • $\begingroup$ I don't see the clipping and collisions when using Magnification. Are you certain that you do, and not only when using FontProperties -> ScreenResolution? The latter only affects fonts, if I recall correctly, therefore the bounding areas do not increase and clipping can occur. $\endgroup$
    – Mr.Wizard
    Jul 30, 2015 at 7:08
  • 1
    $\begingroup$ @Mr.Wizard, the first picture already shows some of the clipping and collisions, and that screenshot is with the default settings (that is, after removing ~/.mathematica completely). I have tried both ways of magnifying, and both seem equivalent in that they both produce clipping. $\endgroup$
    – JP-Ellis
    Jul 30, 2015 at 10:45
  • $\begingroup$ Any updates on this? Would be very happy if this was improved in version 11. $\endgroup$
    – rgrinberg
    Aug 15, 2016 at 17:19

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.