6
$\begingroup$

I was often complaining about the front end performance under Linux, but it seems I could pin down a very critical issue. I made a screen-cast that shows how to reproduce the issue

How to reproduce: Open a fresh Mathematica and type some code. In the screen-cast I used

Hold[Compile[{x, y}, x + y, CompilationTarget -> "C"]]

Don't copy it from here, type it! Evaluate the cell and then just use the arrow keys left and right to scroll though the code. It should go fast and as soon as you release the arrow key, the moving cursor should stop too.

Now, copy the code from here and insert it into the notebook as very first cell. If you now move around, it will go noticeably slower and the there will be a large delay between the release of the arrow key and the stop of the cursor.

Now, use the left arrow key to go through the very beginning of the notebook. It's important that you hold down the arrow key for about 5-10 seconds even when you reached the beginning.

At this point, the front end should be in a very weird state. Either, it inserts left arrow keys only, no matter which key you press, or it just eats some of your keys so thyou endp writngli ths...

Please, pretty please comment, when you can (even partially) reproduce this.

Update:

Today I took the time to mis-use a MacPro to remove everything and install a completely fresh Ubuntu 14.04 TLS and a Mathematica trial version on it. This system is completely empty except of the basic Ubuntu and Mathematica 10.2. I could easily reproduce the issue exactly how I showed in the screencast.

$\endgroup$
8
  • $\begingroup$ I can't reproduce this in Windows with 10.0.2, but we have had problems with key mappings getting mixed up when launching from Eclipse. All of the Cntl key combos stop working properly, and a relaunch is required to fix it. $\endgroup$ Jul 27, 2015 at 13:09
  • 1
    $\begingroup$ @DavidCreech This is clearly a Linux problem only. I had problems like this ever since, but always on Linux only. On OS X (I don't use Windows) everything was and is fine. $\endgroup$
    – halirutan
    Jul 27, 2015 at 13:11
  • $\begingroup$ I haven't been able to reproduce this problem on several Linux systems, including Ubuntu. Does it only happen for you with 10.2 or also with earlier versions? Does it persist if dynamic highlighting is disabled? I would recommend sending more information about your system to support, in particular about any non-default Ubuntu packages or settings used (localization? clipboard manager software? video drivers?), any programs running at the same time as Mathematica etc. $\endgroup$
    – ilian
    Aug 31, 2015 at 18:08
  • $\begingroup$ Thank you very much for giving feedback. Could you provide the CASE number for this issue again? I reported several bugs this day and now I don't know which number this issue was (and support didn't wrote an response until now). I will then try to give as much detail as possible. $\endgroup$
    – halirutan
    Aug 31, 2015 at 18:52
  • $\begingroup$ Case number appears to be 3392676, although I am surprised they don't seem to have done anything with it. $\endgroup$
    – ilian
    Aug 31, 2015 at 19:13

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.