19
$\begingroup$

I realize this won't be a particularly clear question. As I'm not able myself to find a pattern for the problem I'm talking about I won't be able to give enough informations to make it fully reproducible, either. What I'm hoping for is that this is common enough that someone else has already encountered it and found a solution/workaround.

Quite often, Manipulate objects make the notebook freeze, until a message appears notifying me that the Kernel is not responding to Dynamic Evaluation, as you can see in the following snapshot:

enter image description here

This doesn't happen on direct evaluation of the Manipulate function, but as soon as I try to modify a dynamic parameter. In the example above, it happened as soon as I tried to move the x slider.

Aborting evaluation, re-enabling dynamic updating, and re-evaluating the Manipulate statement doesn't solve the issue: the kernel just freezes again. Even restarting the PC doesn't always solve it.

I said always, because sometimes closing and re-opening Mathematica brings things back to normal. Sometimes even just quitting the kernel and retrying the evaluation is enough.

And this is the main problem: I'm not able to find a pattern. What I understood is that when this problem starts to appear, any Manipulate statement stops working. I think there is a trend on this problem coming up mainly on big, complicated notebook, but then it will be present on any notebook.

Does someone have any solution, or even just some tips to find out why such a problem may arise?

I'm using Mathematica 10.1 on a Windows 7 machine, and the problem doesn't show up with Mathematica 10.0 (identical notebooks give the problem on 10.1 and work fine on 10.0).

$\endgroup$
6
  • $\begingroup$ I have not experienced the problem you ran into. Your simple example works fine for me. My observation is that Manipulate and Animate appear to work slower on Mathematica 10 (doing more???) but I have been able to run my most sophisticated Manipulates created in Mathematica 9 on Mathematica 10. $\endgroup$ Jul 25, 2015 at 2:12
  • $\begingroup$ I can not reproduce your problem. It is likely that it is caused by something unique to your installation. I think you will have take this up with WRI tech support. $\endgroup$
    – m_goldberg
    Jul 25, 2015 at 2:12
  • $\begingroup$ I can't reproduce either. Windows 8.1 MMA 10.1 $\endgroup$
    – Murta
    Jul 25, 2015 at 2:29
  • $\begingroup$ @m_goldberg is there a way to diagnose such a problem? $\endgroup$
    – glS
    Jul 25, 2015 at 9:08
  • $\begingroup$ I experienced the same problem with Mathematica 10.1 now and again. $\endgroup$
    – Karsten7
    Jul 27, 2015 at 14:28

3 Answers 3

11
$\begingroup$

I had this problem and the solution was to turn off the Suggestions Bar in the preferences.

$\endgroup$
4
  • $\begingroup$ Had the same problem on V10.2 on Win 10, seems that your solution might work for me $\endgroup$
    – Quit007
    Mar 28, 2017 at 19:34
  • $\begingroup$ This solution works on my strange-behaving Manipulate, which started to experience that weird "kernel not responding" thing after running well for a couple of days. What an insane bug it is. (v 11.0.1) $\endgroup$
    – User18
    Sep 9, 2017 at 6:07
  • $\begingroup$ I had the same problem in Mathematica 11.3 in two different computers, with Windows 8 and Windows 10 respectively. Your solution seems to work in both cases. Thank you. $\endgroup$ Feb 10, 2020 at 11:16
  • $\begingroup$ It is now 2020, Mathematica at version 12.0 and this is still not fixed. $\endgroup$
    – Basti
    Jun 10, 2020 at 16:41
4
$\begingroup$

I had similar problem too. But I found out that if I try this first:

 Manipulate[ 1, {x, -1, 1}]

And manipulate the function. Then it kind of "activate" the Manipulate. After this, Manipulate works as normal.

$\endgroup$
3
  • $\begingroup$ same for me. odd! $\endgroup$ Jul 17, 2017 at 23:52
  • $\begingroup$ Me too, I was banging my head agains the wall for a week here. Thanks. $\endgroup$ Nov 24, 2019 at 9:38
  • $\begingroup$ @Deltaentropy Do you mind to upvote this answer so that more people would see it? :P $\endgroup$
    – taper
    Nov 25, 2019 at 11:08
2
$\begingroup$

I solved this problem (on Windows 7) by holding Ctrl-Shift when starting Mathematica.

The documentation here: http://support.wolfram.com/kb/12464 advises you to backup any customization you have done. What they don't say is that it could in theory be customizations that have intereferd with normal functionality

$\endgroup$
2
  • 1
    $\begingroup$ I have the same problem as the original post - it happens to me more than I like, for sure. I tried this solution to no avail. I'm running 10.3.0.0 on Win 7. $\endgroup$
    – GregH
    Nov 30, 2015 at 15:24
  • $\begingroup$ The solution also worked for my Mathematica 10.2 on windows 10. $\endgroup$
    – ercegovac
    Feb 26, 2016 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.