16
$\begingroup$

I have upgraded the Raspbian installation on my Pi 2 from "Wheezy" (= Debian 7) to "Jessie" (= Debian 8), mainly because I need a more up-to-date G++ compiler for my other projects. Much to my chagrin an unwanted side effect occurred: Mathematica disappeared. There is apparently no package in Jessie for it. I tried the usual sudo apt-get update, sudo apt-get upgrade, to no avail. I asked Wolfram's support, they directed me to the Wolfram Community site where I asked the same question but received no reply. Hence the question here: has anyone managed to install Mathematica 10 under the new Raspbian "Jessie" on a Pi 2?

Apologies if this is not the right place to ask such a question. Instead of downvoting please just let me know and I'll delete the question.

$\endgroup$
  • $\begingroup$ You didn't happen to save the associated *.deb files, in any case? $\endgroup$ – J. M. will be back soon Jul 23 '15 at 7:51
  • 2
    $\begingroup$ As @J.M. mentions, I would try installing the latest deb available with dpkg. $\endgroup$ – ilian Jul 23 '15 at 14:19
  • 2
    $\begingroup$ This thread on the Raspberry Pi forums provides some not-so-optimistic answers. $\endgroup$ – bobthechemist Jul 23 '15 at 14:55
  • $\begingroup$ Possibly the older libharfbuzz could just be copied into the wolfram-engine layout, so as not to affect the entire system. But this is just a guess, I will have a look later today. $\endgroup$ – ilian Jul 23 '15 at 15:10
  • 1
    $\begingroup$ @ilian at the moment, that won't work, and will end up breaking Jessie. Best solution is to convince the WRI folks they need more MMA.SE rep and have them post an answer here :-). $\endgroup$ – bobthechemist Jul 23 '15 at 15:15
15
$\begingroup$

Update

The procedure below should not be necessary any more, if running a fresh install of the official Raspbian Jessie image. See also bobthechemist's comment.


This is what I did to install wolfram-engine on my Raspberry Pi 2 running Raspbian 8 (jessie).

  • Download the latest available deb package and install it with dpkg.

    sudo dpkg -i wolfram-engine_10.0.2+2015020304_armhf.deb

    This will install the package, but leave it unconfigured because of the missing libharfbuzz0a dependency.

  • Open with a text editor the file /var/lib/dpkg/status, find the wolfram-engine section and look for the dependencies line, which should be

    Depends: java7-runtime | java8-runtime, libatlas3-base (>= 3.8.4-9),
    libpango1.0-0 (>= 1.30.0-1), libcairo2 (>= 1.12.2-3),
    libglib2.0-0 (>= 2.33.12+really2.32.4-5), libffi5 (>= 3.0.10-3+b3),
    libpixman-1-0 (>= 0.26.0-4+deb7u1), zlib1g (>= 1:1.2.7.dfsg-13),
    libfontconfig1 (>= 2.9.0-7.1), libfreetype6 (>= 2.4.9-1.1), libpng12-0 (>= 1.2.49-1),
    libexpat1 (>= 2.1.0-1+deb7u1), libuuid1 (>= 2.20.1-5.3),
    libportaudio2, libharfbuzz0a (>= 0.9.19-1co2rpi2)

    then delete the trailing , libharfbuzz0a (>= 0.9.19-1co2rpi2).

  • Let the package configuration complete

    sudo apt-get -f install
  • Logout and login so the desktop icons would appear.

Mathematica will work happily with the system library, /usr/lib/arm-linux-gnueabihf/libharfbuzz.so.0 which is provided by the libharfbuzz0b_0.9.35-2_armhf.deb package and should not break your system in any way.

The issue is mostly cosmetic, due to the name of the dependency being changed in an incompatible way in jessie. I expect it would be addressed in the next release.

$\endgroup$
  • 3
    $\begingroup$ Nice. typically cross-posting is shunned in SE, but I think making mention of this answer at the RPi.SE, especially since they have the same question is worthwhile. $\endgroup$ – bobthechemist Jul 23 '15 at 19:07
  • 1
    $\begingroup$ I have added an answer on RPi.SE to that question that refers to ilian's answer above. You are absolutely correct, cross-referencing is OK in this case because this is both a Mathematica and a RPi issue in a way. Thanks for the heads-up! $\endgroup$ – Laryx Decidua Jul 24 '15 at 8:16
  • $\begingroup$ Re-installed Mathematica today, following ilian's instructions. Confirmed working. Many thanks! +1, answer accepted. $\endgroup$ – Laryx Decidua Jul 25 '15 at 7:38
  • 2
    $\begingroup$ As of SEP-29-2015, the standard image for the RPi is Jessie. This solution should be followed only if the user performed a manual Wheezy to Jessie upgrade. A fresh install of the Jessie distro has Mathematica working out of the box. $\endgroup$ – bobthechemist Nov 11 '15 at 12:49
  • 1
    $\begingroup$ This is a post from 2015 concerning the compatibility of wolfram-engine 10.0.2 with the (then!) new Jessie release... the specific instructions worked just fine for myself and others at the time, of course no one should need to follow them in 2017. $\endgroup$ – ilian May 29 '17 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.