3
$\begingroup$

Running DiscretizeRegion@Cuboid[] from the documentation under Raspbian on the Raspberry Pi 2, Mathematica version 10.0.0.0, gives the following response:

DiscretizeRegion::drf: DiscretizeRegion was unable to discretize the region Cuboid[{0,0,0}].

What is the cause of this?

$\endgroup$
9
$\begingroup$

The Raspberry Pi build does not include certain components. In particular, TetGenLink and TriangleLink are not available which will affect region discretization (and PDE solving over regions etc.)

Update

This has been improved in the latest wolfram-engine release (namely wolfram-engine_10.3.1+2016012407_armhf.deb).

enter image description here

There may still be bits and pieces of the computational geometry functionality that are lagging behind in the Raspberry Pi release, for example boolean operations on meshes.

$\endgroup$
  • $\begingroup$ Thank you for the information, I've tried the option for DiscretizeRegion you suggested, unfortunately it seems to return the same error. $\endgroup$ – image_doctor Jul 14 '15 at 19:17
  • $\begingroup$ @image_doctor My mistake; I wasn't using the released version. Will update the answer if I find a workaround. $\endgroup$ – ilian Jul 14 '15 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.