1
$\begingroup$

This question already has an answer here:

Bug introduced in 10.0 and fixed in 10.0.2


As some of you might know, if you press Control+Shift on windows, you change your keyboard layout. For example, : becomes ±. This happens sometimes in Mathematica, and it results in a weird bug: control z no longer works, even after you change back. Sometimes I'll be writing and suddenly I see ±, so I know I have to press control shift, and I can type : again. However, if I use control z, it opens the wolfram demonstrations page http://demonstrations.wolfram.com/, and so does undo under edit. The only way of getting rid of this is completely quitting Mathematica, which is quite a hassle, especially as I usually find out when I want to actually undo something. This means that I actually cannot undo this, which is very problematic in some cases.

Does anyone have experience with this bug?

$\endgroup$

marked as duplicate by ilian, Michael E2, MarcoB, Öskå, rcollyer Aug 11 '15 at 18:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ In (my) Windows 7 Control-Shift-: does not work the way you describe. Does this feature need to be turned on somewhere? $\endgroup$ – Mr.Wizard Jun 26 '15 at 0:28
  • $\begingroup$ Hm, from what I know is that it changes the keyboard layout. It appears to be under Control Panel -> Regional and Language Options -> Languages tab -> Details. I suppose I could turn off the shortcut, but that still doesn't explain why mathematica changes its undo into opening the demonstrations page, even after switching back layouts. $\endgroup$ – user129412 Jun 26 '15 at 0:46
1
$\begingroup$

This bug has been fixed as of version 10.0.2.

See also these other questions: (58799), (60408), (72750) and (90054).

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.