3
$\begingroup$

I'm getting above error code with a Trap 132 indication when attempting an ArrayPlot of a complex 130000 x 2048 matrix.

Using Mathematica 9.0.1 with Mac OS 10.10.3 & 16GB RAM

My code worked fine with Mathematica 8.0.4 using a sparse matrix of 13000 x 2048.

Any ideas what causes the error?

$\endgroup$
  • $\begingroup$ I think it would useful if you were to add a screen capture of the error message to your question. $\endgroup$ – m_goldberg Jun 22 '15 at 9:13
  • $\begingroup$ Thread 1 crashed with X86 Thread State (32-bit): eax: 0x00000004 ebx: 0x00000000 ecx: 0xb001067c edx: 0x974df8ce edi: 0x9c27a0a0 esi: 0x9c259658 ebp: 0xb00106f8 esp: 0xb001067c ss: 0x00000023 efl: 0x00000247 eip: 0x974df8ce cs: 0x0000000b ds: 0x00000023 es: 0x00000023 fs: 0x00000023 gs: 0x0000000f cr2: 0x01700048 Logical CPU: 0 Error Code: 0x00000171 Trap Number: 132 $\endgroup$ – stqnt Jun 22 '15 at 9:30
  • $\begingroup$ Macintosh or hackintosh? $\endgroup$ – ciao Jun 22 '15 at 9:34
  • $\begingroup$ I asked for a screen capture because I wanted to see the exact form of the message as a clue to its origin. Your comment suggests the message comes for OS X, not Mathematica. Did you experience a kernel crash? Or a front-end crash? $\endgroup$ – m_goldberg Jun 22 '15 at 9:35
  • $\begingroup$ Have you used the Console app to examine the system logs? $\endgroup$ – m_goldberg Jun 22 '15 at 9:37
11
$\begingroup$

This is almost certainly an out-of-memory crash.

The underlying issue is that the OS X front-end is a 32-bit program, so has a process memory limit of around 2 GB. It is normal for an attempted allocation beyond that limit to lead to a crash.

A similar size ArrayPlot example I tried on my Windows machine (where the front-end is 64-bit) used more than 3 GB of RAM according to Task Manager and MemoryInUse[$FrontEnd].

I should mention that our developer team is very aware of this limitation and is working on front-end modernization/creating a full 64-bit Cocoa-based port for OS X. That is not, however, a small project by any means.

$\endgroup$
  • 2
    $\begingroup$ Yep, I've been waiting for years to see this thing go away. That is the really old Carbon (pre Mac OS X!) indication that the app isn't paying attention to you because it's busy, which I still see all the time in the front end. $\endgroup$ – Mark Adler Jul 20 '15 at 3:34
  • $\begingroup$ ilian: Thanks for this explanation. -stqnt $\endgroup$ – stqnt Jul 22 '15 at 15:26
  • $\begingroup$ Can't wait for the 64-bit Mac front end ... I am really really hoping to see it in 11.3 ... I can no longer export some of my notebooks (e.g. IGraph/M documentation) to PDF due to out-of-memory crashes :| $\endgroup$ – Szabolcs Nov 29 '17 at 12:53
  • $\begingroup$ Not for 11.3 as far as I know, but hopefully in the not too distant future. $\endgroup$ – ilian Nov 29 '17 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.