1
$\begingroup$

I tried:

GraphicsRow[{
  ParametricPlot3D[{t, t^2, t^3}, {t, -2, 2},
   AxesLabel -> {"x", "y", "z"},
   BoxRatios -> 1/GoldenRatio,
   ViewPoint -> {0, 0, Infinity}],
  ParametricPlot3D[{t, t^2, t^3}, {t, -2, 2},
   AxesLabel -> {"x", None, "z"},
   BoxRatios -> 1/GoldenRatio,
   ViewPoint -> {0, Infinity, 0}],
  ParametricPlot3D[{t, t^2, t^3}, {t, -2, 2},
   AxesLabel -> {"x", "y", "z"},
   BoxRatios -> 1/GoldenRatio,
   ViewPoint -> {Infinity, 0, 0}]
  }, ImageSize -> 500]

enter image description here

In the second image, I got rid of the axis label using None, but note in the lower right corner I think I have two zeros interfering with one another. Any easy way to get rid of this problem?

$\endgroup$
  • 5
    $\begingroup$ You can specify which axes will show up with the option Axes so for the first image try ParametricPlot3D[...,Axes->{True,True,False}] , for the second use Axes->{True,False,True}, and the third should be obvious. $\endgroup$ – N.J.Evans Jun 12 '15 at 16:20
  • 2
    $\begingroup$ Perfecto! Thanks for the help. $\endgroup$ – David Jun 12 '15 at 18:21
  • 1
    $\begingroup$ @N.J.Evans and David: I would like to encourage NJ to post his solution proposed in the comment as an answer, so that David can properly accept it, and the question will show up as answered. See this post by Ian in MMA.Meta regarding this very situation. $\endgroup$ – MarcoB Jun 15 '15 at 6:02
1
$\begingroup$

The problem is that Mathematica shows all axes by default, which is not ideal for an orthographic projection. You can specify which axes will show up with the option Axes psecifying True or False for each of {x,y,z}. For the first image try ParametricPlot3D[...,Axes->{True,True,False}] , for the second use Axes->{True,False,True}, and the third should be obvious.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.