2
$\begingroup$

When I try to use any version of the Entity functions, the function is returned as if it were undefined. For example, EntityList["Planet"] returns EntityList[Planet]. The help examples don't work either. Is this happening to everyone, or just me?

$\endgroup$
  • $\begingroup$ On my machine, it works fine (Mathematica 10.0.1) $\endgroup$ – Mahdi Jun 5 '15 at 17:51
  • $\begingroup$ I think there is nothing broken in the Entity functions. It's most likely a problem with files in your paclets folder. $\endgroup$ – m_goldberg Jun 5 '15 at 19:04
6
$\begingroup$

Maybe try:

<<EntityFramework`
$\endgroup$
  • $\begingroup$ That did it! I hope that I didn't cause problems by deleting the Paclets folders. $\endgroup$ – George Wolfe Jun 5 '15 at 20:35
  • $\begingroup$ It works, but how to make it default? $\endgroup$ – vito Feb 27 '16 at 10:51
3
$\begingroup$

I'm running V10.1 on OS X 10.10.2 (Yosemite). I ran into this problem about two weeks ago. I solved it by shutting down Mathematica, throwing the Paclets folder found in ~/Library/Mathematica/ into the Trash, and restarting Mathematica. After restarting, I tried the same "Planet" example as you did and it worked (after downloading some new paclets).

I have not had any trouble with Entity expressions since.

$\endgroup$
  • $\begingroup$ Thanks for the suggestion. I deleted the Paclets folders in the ProgramData and AppData>Roaming folders, but it didn't fix the problem. I also did a "clean restart" of Mathematica, but that didn't help either. $\endgroup$ – George Wolfe Jun 5 '15 at 18:41
  • $\begingroup$ @GeorgeWolfe. Sorry it didn't work for you. Are you sure the packet folder you deleted is the only one on your system? I don't recognize the path you mentioned. I guess you aren't on OS X. $\endgroup$ – m_goldberg Jun 5 '15 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.