3
$\begingroup$

I do not know if this is new or not, I googled before.

Windows 7, 10.1 64 bit: Integrals generate this error message

Mathematica graphics

The strange thing also is that the message shows up the first time the command is made (in fresh kernel). Next time Integrate is evaluated, this message do not show up. In both cases the integral is returned unevaluated. (this takes 1-2 minutes to finish, but it does not hang)

ClearAll[a, b, c, d, e, x]; 
p2 = (c*e + d*e*x)^(3/2)*(a + b*ArcCosh[c + d*x])^3
Integrate[p2, x]

Also, The next time it finishes very fast. It seems the first time it is called, it caches some result that is why it returns fast but without the error message. Here is screen shot show showing the two calls:

Mathematica graphics

Another example which generates the same error (multiple times) but this one takes much longer to finish (unevaluated, about 5 minutes on my PC).

ClearAll[a, b, c, d, e, x]; 
p3 = Sqrt[c*e + d*e*x]*(a + b*ArcCosh[c + d*x])^3;
Integrate[p3, x]

Mathematica graphics

Same error show up in version 9 as well.

What can cause this message to show up? Is this a bug?

$\endgroup$
  • 4
    $\begingroup$ Looks like a bug. I've reported it internally. $\endgroup$ – Stefan R May 14 '15 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.